About music recording

by John Cola » Thu, 09 Apr 2009 09:31:06 GMT


Sponsored Links
 When I record an audio(file name:recording22110.amr), the file can
save into SD card via Android default application "MMS->menu->Attach-
I can record this audio and play it!!
But when I go back to Music List, I can't find it in the music list.
After re-insert SD card I still can not find the file. However, after
I "touch" the file and re-insert it back to Android device, the Music
list can now display it.
Anyone know the reason?

BR
John
--~--~---------~--~----~------------~-------~--~----~



About music recording

by chrisk » Thu, 09 Apr 2009 17:18:14 GMT


 The media scanner (AFAIK) only scans at boot time. This is probably
why you don't see the recorded file appear until later.
I will defer and let somebody more knowledgeable answer for sure.

-Chris



--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


About music recording

by Dave Sparks » Fri, 10 Apr 2009 15:02:27 GMT


 It is by intent that voice attachments do not show up in the music
player. Do you really want people to hear these messages when you turn
on party shuffle? :)




--~--~---------~--~----~------------~-------~--~----~



About music recording

by Marco Nelissen » Fri, 10 Apr 2009 17:14:43 GMT


 Files recorded this way show up in the music player in the "My
Recordings" playlist. They are not otherwise treated as music, for the
reason Dave mentioned.





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. TimerTasks getting suspended when the phone is plugged in.

I have an application running TimerTasks.
The TimerTask takes a long time to run (up to 20 minutes).

If the phone is plugged in or unplugged during that time, the timer
task gets suspended for about 10 minutes, or sometimes longer.

Has anyone see this, and is this intended behavior on the Android?

Thanks.

Richard Schilling
Mobile Operating Systems Engineer
Root Wireless

--~--~---------~--~----~------------~-------~--~----~

2. Flashing recovery 1.6...

Wanted to note that I screwed up in the process and it still worked...

I used a miniSD to USB adapter to put the radio file on my miniSD,
then booted up with home+power. Alas, instead of doing ALT+L I goofed
up and ALT+S but it still worked.

Rebooted (HOME+BACK) fine, and very quickly and then I powered off.

Used the USB adapter again, and put the Recovery on the miniSD (again,
renamed as Update), and again HOME+POWER rebooted.

This time I ALT+L, then ALT+S and installed, with no problem.

When I HOME+BACK rebooted, it took awhile to write but came back okay.

So... it doesn't seem like you need to enter the ALT+L command, just
insert the miniSD with the renamed radio image, power up, holding
HOME, then just go straight to pushing ALT+S

To recap, here's what worked for me:

MY ADP1 was upgraded to 1.5, but I never put the new Radio image on
from a while back. I had the first 1.5 radio.

1. Power off phone
2. Download the latest Radio image to your PC
3. Download the latest Recovery image to your PC
4. Rename the Radio, pdate(ensure name is update.zip, not
update.zip.zip)
5. Connect, via USB adapter, miniSD Card to PC
6. Copy update.zip to the root level of the mini sd. DO NOT place in
any folder on miniSD card.
7. Put miniSD in phone
8. Power up phone, holding Power+HOME
9. Phone will appear with a triangle symbol on screen
10. use keyboard and hold ALT + L
11. use keyboard and hold ALT +S, image of a box and phone appear,
with arrow indicated something being installed from box to phone
(unpacking symbol?)
12. Phone will apply update.zip, then prompt you to reboot, use HOME +
BACK to reboot.

green Android logo came up, then blue Android log

13. Power off phone and Remove miniSD card, put in USB adapter in PC
14. delete update.zip from PC and miniSD
15. Rename Recovery image on PC update
16. copy update.zip from PC to miniSD
17. put miniSD in phone
18. press ALT + L (or maybe delete this step)
19. press ALT+ S
20. Again, phone will install update.zip (now the renamed recovery
image), then prompt you to reboot, by pressing HOME + BACK

NOTE: There will be a considerably longer delay during reboot, with
green logo then blue.
--~--~---------~--~----~------------~-------~--~----~

3. Led fix Hero rom

4. Where are android kernel patches available ?

5. getting length of an EditText while entering text

6. activity is destroyed when press home key

7. getting length of an EditText while entering text