Parental Control Android 2.1 for Samsung Moment

by Radwan Shaykho » Wed, 30 Jun 2010 02:51:30 GMT

Parental Control Android 2.1 for Samsung Moment

by Radwan Shaykho » Wed, 30 Jun 2010 02:51:38 GMT

Other Threads

1. Android 1.6-"no sdcard found" error

       I'm a newbie to android porting. We are porting android 1.6
cupcake version  to our OMAP 3530 based board. Previously,we ported
android 1.1 with 2.6.27 kernel to our board and it works fine.
         Now, we have ported android 1.6 with 2.6.29 kernel. When, we
try to open a music player or a camera application in android, it
reports "no sdcard
found"  "Please insert sdcard".
           Previously in android 1.1,we edit the file system/etc/
mountd.conf to specify mount point as /sdcard and block device as /dev/
I have searched previous mails in the group regarding the similar
issue. I found following suggestions.
Edit the vold.conf and add the following line.
    media_path /devices/platform/mmci-omap-hs.0/mmc_host/mmc0
But, I find that vold.conf is not in system/etc/ folder of the android
version. I tried to copy it from android source code to  system/etc/
folder.But, it didn't worked.
   When I checked the source code, the vold.conf is copied
automatically,only when PRODUCT is choosen as sdk. I recompiled
android source code with
PRODUCT=sdk option in makefile.  Still, I find the same error "no
sdcard found"
     Enabling MMC_UNSAFE_RESUME.

Still, my sdcard is not getting detected.
FYI, our sdcard has two partitions.
First partition is used as rootfs of ext3 type
Second partition is of vfat type,which needs to be mounted.

Is there anything, I need to change in android source code or
kernel??.Please give me suggestions to fix the issue.



2. getHeight() of TextView in TableRow problem

I have a very odd problem - or perhaps it's just odd to me.

I have an Activity in which I have a TableLayout. I fill the table
with TableRows in which I display TextViews. Imagine this as a
classical table with text content. After the loop is finished I want
to read all the heights in pixels of all the TextView in this table. I
do this with getHeight().

The problem I have now is that ALL the values are 0 (zero) pixels.
Even though I have text in the TextViews. The odd thing about this is,
if I read the height of the exact same TextViews in an OnClickListener
() then I do get the real height of the elements. Why is that so? I
mean, nothing has changed in the height of those elements in the time
between filling the table and firing the OnClickListener().
I really need to be able to get the height of the TextViews right
after I filled the table. To get the heights upon a click is too late
already for what I want to do.

Any ideas?
Thanks in advance!


3. "Sorry Cant play this video.. trying to play video from youtube

4. Call Log Questions

5. When linux version 2.6.32 will be used?

6. android:mimeType="text/XXX" cannot work on eclair

7. Classification of Applications