assets referenced in HTML

by miketra » Mon, 02 May 2011 07:12:52 GMT

Sponsored Links
 I have an app that includes HTML files in the assets folder. I am able
to load the initial HTML page successfully under all conditions using
the following command in code:


Now, within start_page.htm, I have a bunch of links that can be
clicked, and each link references another HTML file that I have
included in the assets folder.

For some strange reason, all the links load fine on my Droid (2.2.2),
but none of the links load on a Droid X (2.2.1). The links are setup
like this on my Droid inside of start_page.htm:

<a href="page2.htm">Page 2</a>

The above works on the Droid, but not on Droid X. I then tried the

<a href="file:///android_asset/page2.htm">Page 2</a>

This also does not work on Droid X, but works fine otherwise. Does
anyone know why this may be? On the emulator running 2.2.1, it works
fine. I'm not sure what else to try, and I'm not sure what the problem
could be.




Other Threads

1. Usage of Zoom Controls

Hello All,

We have a requirement from customer where we need to implement zoom
controls for a screen activity like webview/mapview.

Can anybody give an idea to accomplish that using Android API for
"ZoomButtonController" or similar stuff? It would be appreciated if
anybody can share a though soon on this.

Thanks in advance for any response.



2. published app not found by android market search

I have published an application. I have two beta users that have
utilized android market to download the application. They downloaded
and installed the app and it worked. This activity was a month or so
ago. The application does show up in my Developer Console today.

But when I search for the application, it is not found.

I search for the application exactly as the name appears in developer
console. I search for the application with just the name w/o the

Thanks, John Brown


3. Dalvik execution mode

4. Need some help please

5. Formatting a Preference Summary

6. a different list mechanism

7. finish doesn't call onDestroy on Android 2.2