by strazzere » Fri, 10 Apr 2009 10:28:54 GMT

Sponsored Links
 Are there any examples of how to use android.permission.GET_ACCOUNTS ?
Or is this an unimplimented api? I found this site; 

Though I haven't been able to get anything to work. I believe JBQ said
it was a private api - but I'm not sure why the permission is listed
on the dev reference?


by Dianne Hackborn » Fri, 10 Apr 2009 10:45:24 GMT

 We unfortunately left most of the permission string constants in the SDK,
even for ones protecting private APIs.  So something being there doesn't
mean there is an API for it.

Dianne Hackborn
Android framework engineer

Note: please don't send private questions to me, as I don't have time to
provide private support, and so won't reply to such e-mails.  All such
questions should be posted on public forums, where I and others can see and
answer them.


Sponsored Links

Other Threads

1. Multiple view in Listview

Hi ,
I have created listview with multiple view in one raw.
Now I have imageview in raw and want to take click event of this view.
So Is there anybody who have solved this issue.
What should I do?
Thanks in advance.


2. "ERROR: the user data image is used by another emulator. aborting"

I have read the many threads regarding this issue, but none of the
proposed solutions has actually solved the problem for me. And judging
by the frequency of threads about it, that hasn't solved it for a lot
of other people either. =)

Here's the problem: When I run my code, seemingly out of nowhere I'll
get the error shown in the subject line:

     ERROR: the user data image is used by another emulator. aborting

This *seems* straightforward, but I only have one emulator running. =\
As evidence, please see this screenshot:


This happens after I run a varying number of successful executions.
Sometimes I may get three in before the error, sometimes I may get
twenty. In this most recent case I had probably run the code fif{*filter*}
times in 45 minutes. Here's the output from the console:


When this happens, I can try to run it as many times as I like, but
I'll continue to get the same error every time:

     [2009-11-12 20:14:21 - AnalogClockWidget]Android Launch!
     [2009-11-12 20:14:21 - AnalogClockWidget]adb is running normally.
     [2009-11-12 20:14:21 - AnalogClockWidget]No Launcher activity
     [2009-11-12 20:14:21 - AnalogClockWidget]The launch will only
sync the application package on the device!
     [2009-11-12 20:14:21 - AnalogClockWidget]Performing sync
     [2009-11-12 20:14:21 - AnalogClockWidget]Automatic Target Mode:
launching new emulator with compatible AVD 'savd2'
     [2009-11-12 20:14:21 - AnalogClockWidget]Launching a new emulator
with Virtual Device 'savd2'
     [2009-11-12 20:14:21 - Emulator]emulator: ERROR: the user data
image is used by another emulator. aborting

The first million times this happened I thought there might be some
sort of conflict with having more than one AVD set up -- maybe somehow
one started automatically if the other was busy or something -- so I
finally deleted all my AVDs and created one single AVD that is now the
only one in existence. Here is a screenshot of the SDK and AVD manager
showing that there is only one AVD{*filter*} around:


The problem is fixable by closing the emulator and making a new one,
but as we all know that takes a painful 3-6 minutes each time.

Does anybody know what could be causing this? The first twenty times I
restarted the emulator this afternoon, I was able to spend the
intervening five minutes straightening up the kitchen. But I'm running
out of stuff to clean. =(



3. How to answer comments on your apps

4. Analytics for Android Apps - issue getting the SDK

5. setting taxes for Android Market

6. Scrolling large image - working good but slow

7. how to hide keyboard when done typing