WMV codec question

by Wei » Thu, 08 Jan 2009 03:38:15 GMT


Sponsored Links
 Hi all,

As I know the WMV codec is the value add feature for PV OpenCORE.
What kind of wmv codec support by PV? WMV 8, WMV 9, VC-1

BRs,
weichung
--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by Wei » Thu, 08 Jan 2009 03:41:14 GMT


 Hi all,

As I know the WMV codec is the value add feature for PV OpenCORE.
Is any one know what kind of wmv codec support by PV? WMV 8, WMV 9,
VC-1


BRs,
Wei
--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


WMV codec question

by rktb » Thu, 08 Jan 2009 03:50:17 GMT


 Hi,

VC-1 is the standard. WMV9 is an implementation. PV supports WMV7,
WMV8, and WMV9.


-Ravi



--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by Weichung Tseng » Thu, 08 Jan 2009 04:30:02 GMT


 Hi Ravi,

If we have VC-1 HW codec, is the PV wmv parser support the HW decoder?

- wei

2009/1/8 rktb <yend...@pv.com>



--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by rktb » Thu, 08 Jan 2009 05:07:13 GMT


 Hi,

Is your codec OMX compliant? Or, do you plan to wrap it inside it's
own node?

-Ravi




--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by Wei » Thu, 08 Jan 2009 06:18:19 GMT


 Hi,

The codec will be a OMX compliant.
I hope I can use pv decoder node.






--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by rktb » Thu, 08 Jan 2009 09:24:31 GMT


 Ok. The ASF parser should then be able to support your OMX codec.

-Ravi






--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by Wei » Fri, 09 Jan 2009 02:11:58 GMT


 okay,
the ASF parser need to license, is that correct?





--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by Wei » Fri, 09 Jan 2009 03:19:03 GMT


 okay,
the ASF parser need to license, is that correct?
And the VC-1 can not compatibly with wmv7 & 8,
Is the parser supoort to separate to wmv 7/8 & wmv 9 for HW OMX
codec?

~ wei




--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by umesh » Fri, 06 Mar 2009 23:26:27 GMT


 So whatever the android open source we get does it support VC-1
software code  (wmv9,wmv8,wmv7).
Because whenever I am trying to play the file I get error  E/
MediaPlayer( 1119): error (-4, 0)  that mean not supported.




--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by rktb » Sat, 07 Mar 2009 00:07:43 GMT


 Yes. ASF parser needs to be licensed.

The parser is the same irrespective of the codec.


-Ravi




--~--~---------~--~----~------------~-------~--~----~



WMV codec question

by rktb » Sat, 07 Mar 2009 00:10:09 GMT


 OpenCORE does not support VC1/WMV.

-Ravi





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. How to statically link SQLite against my app

I've hit an SQLite bug (mentioned here:
http://old.nabble.com/Android-database-corruption-td28044218.html#a28044218)
that affects the version of SQLite bundled with < 2.2 Android.

What I'd like to do is bundle a newer version of SQLite along with my
app.

I've been told that I can use the NDK to do this, but I get errors
when I try to compile it. Here's the output:

Compile thumb  : sqlite3 <= ###/eclipse/workspace/TestApp/jni/
sqlite3.c
###/eclipse/workspace/TestApp/jni/sqlite3.c: In function
'unixDlError':
###/eclipse/workspace/TestApp/jni/sqlite3.c:26415: warning: assignment
discards qualifiers from pointer target type
SharedLibrary  : libsqlite3.so
###/eclipse/workspace/TestApp/obj/local/armeabi/objs/sqlite3/
sqlite3.o: In function `unixDlSym':
###/eclipse/workspace/TestApp/jni/sqlite3.c:26442: undefined reference
to `dlsym'
###/eclipse/workspace/TestApp/obj/local/armeabi/objs/sqlite3/
sqlite3.o: In function `unixDlClose':
###/eclipse/workspace/TestApp/jni/sqlite3.c:26446: undefined reference
to `dlclose'
###/eclipse/workspace/TestApp/obj/local/armeabi/objs/sqlite3/
sqlite3.o: In function `unixDlError':
###/eclipse/workspace/TestApp/jni/sqlite3.c:26415: undefined reference
to `dlerror'
###/eclipse/workspace/TestApp/obj/local/armeabi/objs/sqlite3/
sqlite3.o: In function `unixDlOpen':
###/eclipse/workspace/TestApp/jni/sqlite3.c:26401: undefined reference
to `dlopen'
collect2: ld returned 1 exit status
make: *** [###/eclipse/workspace/TestApp/obj/local/armeabi/
libsqlite3.so] Error 1

Can someone help me with this? I'm a complete novice when it comes to
compiling/building.

Thanks!

-- 

2. $99 Apple iTV?! will Google TV be $49???

http://www.crunchgear.com/2010/08/11/report-the-next-gen-apple-tv-to-be-called-itv-cost-99-and-limited-to-720p-its-going-to-be-cheap-and-thats-fine/

-- 

3. Using ContentResolver.query() returns null

4. How can I intercept outgoing SMS's?

5. Android Porting on Hawkboard

6. Newbie but quite excited

7. Query regarding Intent.get & Extras.