Video Application opening error.

by pramod » Tue, 10 Mar 2009 04:33:00 GMT


Sponsored Links
 i

i have ported android onto the OMAP 3430 board. The android boots
properly. But while opening the video applicatoin it quits.No error
message is displayed on the screen.

on running the logcat i got the following log.

I/ActivityManager( 801): Starting activity: Intent
{ action=android.intent.action.MAIN categories={
android.intent.category.LAUNCHER} flags=0x10200000 comp=
{com.android.music/com.android.music.VideoBr
owserActivity} }
I/ActivityManager( 801): Start proc com.android.music for activity
com.android.music/.VideoBrowserA
ctivity: pid=987 uid=10022 gids={3003}
I/ActivityManager( 801): Start proc android.process.media for content
provider com.android.provider
s.media/.MediaProvider: pid=995 uid=10010 gids={1006, 3003, 2001}
I/ActivityThread( 995): Publishing provider downloads:
com.android.providers.downloads.DownloadProv
ider
I/ActivityThread( 995): Publishing provider drm:
com.android.providers.drm.DrmProvider
I/ActivityThread( 995): Publishing provider media:
com.android.providers.media.MediaProvider
V/MediaProvider( 995): Attached volume: internal
V/MediaProvider( 995): /sdcard volume ID: 1236609404
V/MediaProvider( 995): Attached volume: external
W/InputManagerService( 801): Starting input on non-focused client
com.android.internal.view.IInputM
ethodclient$stub$pr...@43571880 (uid=10001 pid=843)
I/ActivityManager( 801): Displayed activity
com.android.music/.VideoBrowserActivity: 401 ms
I/ActivityManager( 801): Exiting empty application process
android.process.media (android.os.Binder
pr...@43470498)
I/Process ( 801): Sending signal. PID: 995 SIG: 9
I/ActivityThread( 987): Removing dead content provider: media
I/ActivityManager( 801): Killing app com.android.music (pid 987)
because provider com.android.provi
ders.media.MediaProvider is in dying process android.process.media
I/Process ( 801): Sending signal. PID: 987 SIG: 9
I/WindowManager( 801): WIN DEATH: Window{4352f2f0 com.android.music/
com.android.music.VideoBrowserA
ctivity}
I/ActivityManager( 801): Process com.android.music (pid 987) has
died.
I/ActivityManager( 801): Low Memory: No more background processes.
D/dalvikvm( 801): GC freed 3353 objects / 186184 bytes in 141ms
D/ActivityManager( 801): Received spurious death notification for
thread android.os.binderpr...@434
70498
E/InputManagerService( 801): Got RemoteException sending setActive
(false) notification
E/InputManagerService( 801): android.os.DeadObjectException
E/InputManagerService( 801): at android.os.BinderProxy.transact
(Native Method)
E/InputManagerService( 801): at
com.android.internal.view.IInputMethodClient$Stub$Proxy.setActive
(IInputMethodClient.java:158)
E/InputManagerService( 801): at
com.android.server.InputMethodManagerService.unbindCurrentInputLo
cked(InputMethodManagerService.java:549)
E/InputManagerService( 801): at
com.android.server.InputMethodManagerService.startInputLocked(Inp
utMethodManagerService.java:609)
E/InputManagerService( 801): at
com.android.server.InputMethodManagerService.startInput(InputMeth
odManagerService.java:693)
E/InputManagerService( 801): at
com.android.internal.view.IInputMethodManager$Stub.onTransact(IIn
putMethodManager.java:113)
E/InputManagerService( 801): at
com.android.server.InputMethodManagerService.onTransact(InputMeth
odManagerService.java:461)
E/InputManagerService( 801): at android.os.Binder.execTransact
(Binder.java:276)
E/In



Video Application opening error.

by kozak » Wed, 11 Mar 2009 07:13:48 GMT


 i Pramod,
Seems like you are out of memory! Try increasing the available
memory.

Regards
Kozak

On Mar 10, 9:32 am, pramod <pramodkum...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---


Sponsored Links


Video Application opening error.

by susanner » Wed, 11 Mar 2009 07:28:25 GMT


 ay I ask how to increase the available memory? you mean change the real hard 
ware board? can I implement through change my programs? Is this because of
empty application? the catlog shows



what does this mean?

009-03-11ozak <c.a.subraman...@gmail.com> >

--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---



Video Application opening error.

by kozak » Wed, 11 Mar 2009 08:05:41 GMT


 ry changing available memory in bootargs set in u-boot! Thats one of
the ways it worked out for us during the bootup phase.
Regards
Kozak

On Mar 11, 12:28 pm, susanner <zsusan...@163.com> wrote:
--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---



Video Application opening error.

by pramod » Wed, 11 Mar 2009 08:53:49 GMT


 i kozak,

The problem is solved. I patched the android kernel with omap patches
and now the video application is working properly.


On Mar 11, 1:05 pm, kozak <c.a.subraman...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---



Video Application opening error.

by Kenny » Thu, 12 Mar 2009 01:35:22 GMT


 here did you find the TI patches? Can you share with me?
Thanks,
Kenny

On Mar 11, 4:53 pm, pramod <pramodkum...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---



Other Threads

1. startActivity called from non-Activity context - help

This message appeared in logcat when selecting a notification ...

startActivity called from non-Activity context; forcing
Intent.FLAG_ACTIVITY_NEW_TASK for: Intent {
comp={com.blah.blahs/com.blah.blahs.Blahs} (has extras) }

It brings the Activity into focus which is half the battle ... thing is, I
have no idea what function to read the intent details from.  It does not
call onCreate ... or startActivity.

I have posted this several times ... feeling a bit stuck.  Help super
appreciated.

j

--~--~---------~--~----~------------~-------~--~----~

2. wifi icon always shows no bars

I know my G1's status bar wifi icon used to give some indication of
signal strength (it never got very many bars, we all know the G1's
antenna is a little weak), but recently I never see any bars at all.
I am currently holding my G1 one or two feet away from the hub of a
wifi connection, and still, no bars whatsoever in the status bar icon
after several minutes and in several nearby locations around the room.

Since this is a recent change, I'm wondering if this is this a Cupcake
bug.  Can one else verify that the wifi icon never shows any bars
whatsoever......or equally important, can anyone verify that it *does*
show bars sometimes and I'm just getting strange behavior?

Thanks.
--~--~---------~--~----~------------~-------~--~----~

3. listeners in popupwindow

4. I just have to say thanks to google. The iPhone review process was killing me, but this is great

5. Android NDK problem withe samples

6. Retrieving Google/GTalk Account bound to Android?

7. Control standardization - Moving forward