Is there a video clip that actually plays on emulator

by mobi » Mon, 03 Nov 2008 13:40:24 GMT

Sponsored Links
 I have tried several video clips in different formats  - 3gp, mp4, wmv
but could not get any of these to play on the emulator. I have written
programs from scratch for playing video, downloaded code from the web
(pretty much same as what I wrote), tried the web browser (with an SD
card image)  and have tried the API demo code by changing the "path"
value in class to point
to a URL on my local http server where I keep the video clips (I did
check the mime type on the http server) . I keep on getting error
"'Cannot play video' Sorry, this video cannot be played". Am using
version 1.0 release 1  on windows XP.

So heres the question - has any of you actually gotten a video to play
on the emulator and if yes, can you share the clip (and code) if



Other Threads

1. How to rotate?


    I am trying to rotate an image for every 3 secs, but it's not working. I
did like this
but not working..what may be the reason..?

public class TimerEx extends Activity {
 Timer timer;
     ImageView image;
 Bitmap bMap = null;
 Bitmap bitmap;
Matrix mat = new Matrix();
public void onCreate(Bundle savedInstanceState) {
System.out.println("Inside create");
 image = (ImageView) findViewById(;
 bMap = BitmapFactory.decodeResource(getResources(), R.drawable.image);
      timer=new Timer();
      timer.schedule(new UpdateImage(),100,3000);
class UpdateImage extends TimerTask
public void run() {
bitmap=Bitmap.createBitmap(bMap,0,0, bMap.getWidth(), bMap.getHeight(),
 mat, false);


2. Zygote process is restarting?

I had a mp4 player running on arm chip on which I am porting android
2.1. The hardware has all the requirements to port android.

I had configured the kernel by enabling android options and also
compiled the android stack. I am flashing the player using a tool in
which I can able to make partitions. I had made 2 FAT partitions and
copied system folder into one partition, data folder into other and
flashed the kernel image.

But when I restart the system; kernel was working fine but zygote
process is getting killed and restarting everytime. Can someone please
help me how to fix it?

In code init.c, this part is being executed always:

        if (ufds[2].revents == POLLIN) {
            /* we got a SIGCHLD - reap and restart as needed */
            read(signal_recv_fd, tmp, sizeof(tmp));
            while (!wait_for_one_process(0))
//              ERROR("=====here===2+\n");



3. [WTA] Gis application in Android

4. Implementing a grid with horizontal, vertical and diagonal scroll

5. What kind of system images *can* you run in the emulator..?

6. Anyone ever used androidpit's lvl mechanism? Is it trustworthy?

7. FilterQueryProvider not working