SDK 1.5 Build Error

by Chris McCurdy » Thu, 16 Apr 2009 01:05:43 GMT


Sponsored Links
 I'm attempting to test one of my applications in the SDK1.5
environment, but when it tries to build, I get this error:

[2009-04-15 12:33:13 - Battle Bricks]
trouble processing "java/awt/font/NumericShaper.class":
[2009-04-15 12:33:13 - Battle Bricks]
Attempt to include a core VM class in something other than a core
library.
It is likely that you have attempted to include the core library from
a desktop
virtual machine into an application, which will most assuredly not
work. If
you really intend to build a core library -- which is only appropriate
as
part of creating a full virtual machine binary, as opposed to
compiling an
application -- then use the "--core-library" option to suppress this
error
message. If you go ahead and use "--core-library" but are in fact
building
an application, then please be aware that your build will still fail
at some
point; you will simply be denied the pleasure of reading this helpful
error
message.

But I've tested my other application in the environment, and it worked
fine. I've looked through my imports, and none of my files import
NumericShaper, so I'm confused as to why it seems to think that it is
being referenced.
--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by Aaron » Thu, 16 Apr 2009 12:50:53 GMT


 I also met this issue today, when I tried to build a project created
in previous enviroment.
I solved it in this way.

1. Remove folders under project except src and res. remove files under
project folder except AndroidManifest.xml
2. Create a project from existing source
3. Change java compile compliance level from 1.6 to 1.5 (not sure if
it is needed)

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


SDK 1.5 Build Error

by Raphael » Fri, 17 Apr 2009 08:15:17 GMT


 Do you have external JAR files or anything else that's trying to bring
that awt class?
R/

On Wed, Apr 15, 2009 at 10:05 AM, Chris McCurdy



--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by Karima » Fri, 24 Apr 2009 19:46:40 GMT


 I met this today.
I solved it :
In your project's folder the file .classpath is wrong. The good file
is :
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
        <classpathentry kind="src" path="src"/>
        <classpathentry kind="src" path="gen"/>
        <classpathentry kind="con"
path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK"/>
        <classpathentry kind="output" path="bin"/>
</classpath>



--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by hiroaok » Wed, 29 Apr 2009 15:04:26 GMT


 Please create new project for your application on eclipse.

The issue was happened when I imported existing project to eclipse.

It's easy way to fix.

BRs,
Aoki





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. "Divide by zero" in IconMenuView.layoutItemsUsingGravity()

Hi,

One of my users reported a strange issue today (the app in question is
here: market://details?id=com.ptashek.bplog).
The general layout is a TabActivity hosting three tabs, each populated
using an Intent.

seems there is a "divide by zero" exception raised on line 216 in
IconMenuView.java, as seen here:

http://android.git.kernel.org/?p=platform/frameworks/base.git;a=blob;f=core/java/com/android/internal/view/menu/IconMenuView.java;h=bba2ee27556214a9d28605bda26d6bd36d41f48e;hb=1a3786a3e34112e3e68e6a9b07ba72802867a002

As I understand it this should happen only if I would try to show a
menu without actually adding any menu items to it, right? I am
populating/managing my menus in the target activities using
onPrepareOptionsMenu() and onCreateOptionsMenu().

I have tested my app extensively on all SDKs from 1.5 to 2.2
(including plenty of "random abuse" by the "Click Monkey") and this
issue never came up, and so far none of my users have reported this
kind of error (until today). I don't think this is caused by any of my
code as such, but then again I am new to Android and maybe have missed
something obvious/obscure.

I'd appreciate any hints/pointers etc. :)
Thanks in advance!

Here's the entire logcat from the actual error report:

java.lang.ArithmeticException: divide by zero
  at
com.android.internal.view.menu.IconMenuView.layoutItemsUsingGravity(IconMenuView.java:
216)
  at
com.android.internal.view.menu.IconMenuView.layoutItems(IconMenuView.java:
192)
  at
com.android.internal.view.menu.IconMenuView.onMeasure(IconMenuView.java:
469)
  at android.view.View.measure(View.java:7964)
  at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:
3023)
  at android.widget.FrameLayout.onMeasure(FrameLayout.java:245)
  at android.view.View.measure(View.java:7964)
  at android.view.ViewRoot.performTraversals(ViewRoot.java:763)
  at android.view.ViewRoot.handleMessage(ViewRoot.java:1633)
  at android.os.Handler.dispatchMessage(Handler.java:99)
  at android.os.Looper.loop(Looper.java:123)
  at android.app.ActivityThread.main(ActivityThread.java:4363)
  at java.lang.reflect.Method.invokeNative(Method.java:-2)
  at java.lang.reflect.Method.invoke(Method.java:521)
  at com.android.internal.os.ZygoteInit
$MethodAndArgsCaller.run(ZygoteInit.java:860)
  at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:618)
  at dalvik.system.NativeStart.main(NativeStart.java:-2)

/Lukasz

-- 

2. AudioHardware pcm playback is going to standby

Bumping this. Still having this issue, and I cannot seem to find any
good information anywhere regarding how I can resolve this.  Any help
would be really appreciated.




-- 

3. I want to setting ---screen timeout---!!

4. Workaround

5. scroll not support with javascript in webview

6. Issue with the Unnamed unions in Android.

7. no database directory in package