SDK 1.5 Build Error

by Chris McCurdy » Thu, 16 Apr 2009 01:05:43 GMT


Sponsored Links
 I'm attempting to test one of my applications in the SDK1.5
environment, but when it tries to build, I get this error:

[2009-04-15 12:33:13 - Battle Bricks]
trouble processing "java/awt/font/NumericShaper.class":
[2009-04-15 12:33:13 - Battle Bricks]
Attempt to include a core VM class in something other than a core
library.
It is likely that you have attempted to include the core library from
a desktop
virtual machine into an application, which will most assuredly not
work. If
you really intend to build a core library -- which is only appropriate
as
part of creating a full virtual machine binary, as opposed to
compiling an
application -- then use the "--core-library" option to suppress this
error
message. If you go ahead and use "--core-library" but are in fact
building
an application, then please be aware that your build will still fail
at some
point; you will simply be denied the pleasure of reading this helpful
error
message.

But I've tested my other application in the environment, and it worked
fine. I've looked through my imports, and none of my files import
NumericShaper, so I'm confused as to why it seems to think that it is
being referenced.
--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by Aaron » Thu, 16 Apr 2009 12:50:53 GMT


 I also met this issue today, when I tried to build a project created
in previous enviroment.
I solved it in this way.

1. Remove folders under project except src and res. remove files under
project folder except AndroidManifest.xml
2. Create a project from existing source
3. Change java compile compliance level from 1.6 to 1.5 (not sure if
it is needed)

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


SDK 1.5 Build Error

by Raphael » Fri, 17 Apr 2009 08:15:17 GMT


 Do you have external JAR files or anything else that's trying to bring
that awt class?
R/

On Wed, Apr 15, 2009 at 10:05 AM, Chris McCurdy



--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by Karima » Fri, 24 Apr 2009 19:46:40 GMT


 I met this today.
I solved it :
In your project's folder the file .classpath is wrong. The good file
is :
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
        <classpathentry kind="src" path="src"/>
        <classpathentry kind="src" path="gen"/>
        <classpathentry kind="con"
path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK"/>
        <classpathentry kind="output" path="bin"/>
</classpath>



--~--~---------~--~----~------------~-------~--~----~



SDK 1.5 Build Error

by hiroaok » Wed, 29 Apr 2009 15:04:26 GMT


 Please create new project for your application on eclipse.

The issue was happened when I imported existing project to eclipse.

It's easy way to fix.

BRs,
Aoki





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. question about TableLayout

<RadioGroup
        android:id="@+id/
Radiogroup"
        
android:layout_width="fill_parent"
        
android:layout_height="wrap_content"
        
android:orientation="vertical"
<TableLayout
        android:id="@+id/
widget28"
        
android:layout_width="fill_parent"
        
android:layout_height="fill_parent"
        
android:orientation="vertical"
        xmlns:android="http://schemas.android.com/apk/res/
android"
        
<TableRow>
        
<RadioButton
                        android:id="@+id/
radioNumber"
        
android:layout_width="wrap_content"
        
android:layout_height="wrap_content"
                        android:text="@string/
number"
        
android:layout_marginRight="1dip"
                        /
        
<RadioButton
                        android:id="@+id/
radioCharter"
        
android:layout_width="wrap_content"
        
android:layout_height="wrap_content"
                        android:text="@string/
character"
        
android:layout_marginRight="1dip"
                        /
  </
TableRow>
 
<TableRow>
        
<RadioButton
                        android:id="@+id/
radioMix"
        
android:layout_width="wrap_content"
        
android:layout_height="wrap_content"
                        android:text="@string/
mix"
                        /
                </
TableRow>
        </
TableLayout>
</
RadioGroup>

    it's my xml config file.when  I add the tableLayout into the
raidogroup. I find that I can select more than one radiobutton at one
time.
    Does anyone konw how to fixed it?
--~--~---------~--~----~------------~-------~--~----~

2. How to enable soft keyboard?

Hi,

As title, is there anyone knows how to make the soft keyboard show up?
I am running Android-1.5 on x86 platform and any help is appreciated.

Regards,
Fred
--~--~---------~--~----~------------~-------~--~----~
unsubscribe: android-porting+unsubscr...@googlegroups.com
website: 

3. Open gmail attachments (xml) with another App

4. setLayoutParams on a TextView prevents TextView from being displayed

5. Google to assist overcome piracy

6. Numeric-Only Virtual Keypad

7. glCompressedTexImage2D formats