port openRecordStore from J2ME to android

by Tony Chan » Mon, 27 Apr 2009 22:43:36 GMT


Sponsored Links
 which class I should be using to do that?
Thanks
Tony

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Active Calendar app on Android Emulator?

Hi, all,

I am sorry to bring this into such a board audience but seems nobody
has posted similar problem or solution on the internet.

I am trying to use Calendar.apk in the emulator on a windows xp
system. The SDK version I am using is 1.1r1. However, the calendar app
will always go away with a message "Your events will appear shortly".
My guess is that the app is bound with Google account so I go to
"Setup"->"Data Synchronization". Once I click the "Data
Synchronization", I got a failure reading "The application Google Apps
(process com.google.process.gapps) has stopped unexpectedly. Please
try again". By check logcat output, I got the following(see the msg at
the end). Anybody can help me out how to install the App/Service or
configure the service or activate the signin service so that I can use
Calendar on emulator? Your help is highly appreciated.

I/ActivityManager(   52): Starting activity: Intent
{ action=android.intent.acti
on.MAIN comp={com.android.settings/
com.android.settings.SyncSettings} }
W/GoogleLoginService(  181): Device has no accounts: sending Intent
{ action=and
roid.accounts.LOGIN_ACCOUNTS_MISSING }
I/GoogleLoginService.PasswordEncrypter(  181): no public key available
I/ActivityManager(   52): Stopping service:
com.google.android.googleapps/.Googl
eLoginService
I/ActivityManager(   52): Displayed activity
com.android.settings/.SyncSettings:
 883 ms
I/ActivityManager(   52): Starting activity: Intent { comp=
{com.google.android.g
oogleapps/com.google.android.googleapps.RunSetupWizardActivity} (has
extras) }
I/ActivityManager(   52): Start proc com.google.process.app for
activity com.goo
gle.android.googleapps/.RunSetupWizardActivity: pid=449 uid=10016 gids=
{3003}
I/ActivityManager(   52): Starting activity: Intent { comp=
{com.android.setupwiz
ard/com.android.setupwizard.AccountIntroActivity} (has extras) }
D/AndroidRuntime(  449): Shutting down VM
W/dalvikvm(  449): threadid=3: thread exiting with uncaught exception
(group=0x4
000fe68)
E/AndroidRuntime(  449): Uncaught handler: thread main exiting due to
uncaught e
xception
E/AndroidRuntime(  449): java.lang.RuntimeException: Unable to start
activity Co
mponentInfo{com.google.android.googleapps/
com.google.android.googleapps.RunSetup
WizardActivity}: android.content.ActivityNotFoundException: Unable to
find expli
cit activity class {com.android.setupwizard/
com.android.setupwizard.AccountIntro
Activity}; have you declared this activity in your
AndroidManifest.xml?
E/AndroidRuntime(  449):        at
android.app.ActivityThread.performLaunchActiv
ity(ActivityThread.java:2141)
E/AndroidRuntime(  449):        at
android.app.ActivityThread.handleLaunchActivi
ty(ActivityThread.java:2157)
E/AndroidRuntime(  449):        at android.app.ActivityThread.access
$1800(Activi
tyThread.java:112)
E/AndroidRuntime(  449):        at android.app.ActivityThread
$H.handleMessage(Ac
tivityThread.java:1581)
E/AndroidRuntime(  449):        at android.os.Handler.dispatchMessage
(Handler.ja
va:88)
E/AndroidRuntime(  449):        at android.os.Looper.loop(Looper.java:
123)
E/AndroidRuntime(  449):        at android.app.ActivityThread.main
(ActivityThrea
d.java:3739)
E/AndroidRuntime(  449):        at
java.lang.reflect.Method.invokeNative(Native
Method)
E/AndroidRuntime(  449):        at java.lang.reflect.Method.invoke
(Method.java:5
15)
E/AndroidRuntime(  449):        at com.android.internal.os.ZygoteInit
$MethodAndA
rgsCaller.run(ZygoteInit.java:739)
E/AndroidRuntime(  449):        at
com.android.internal.os.ZygoteInit.main(Zygot
eInit.java:497)
E/AndroidRuntime(  449):        at dalvik.system.NativeStart.main
(Native Method)

E/AndroidRuntime(  449): Caused by:
android.content.ActivityNotFoundException: U
nable to find explicit activity class {com.android.setupwizard/
com.android.setup
wizard.AccountIntroActivity}; have you declared this activity in your
AndroidMan
ifest.xml?
E/AndroidRuntime(  449):        at
android.app.Instrumentation.checkStartActivit
yResult(Instrumentation.java:1467)
E/AndroidRuntime(  449):        at
android.app.Instrumentation.execStartActivity
(Instrumentation.java:1441)
E/AndroidRuntime(  449):        at
android.app.Activity.startActivityForResult(A
ctivity.java:2526)
E/AndroidRuntime(  449):        at
com.google.android.googleapps.RunSetupWizardA
ctivity.onCreate(RunSetupWizardActivity.java:50)
E/AndroidRuntime(  449):        at
android.app.Instrumentation.callActivityOnCre
ate(Instrumentation.java:1122)
E/AndroidRuntime(  449):        at
android.app.ActivityThread.performLaunchActiv
ity(ActivityThread.java:2104)
E/AndroidRuntime(  449):        ... 11 more
I/Process (   52): Sending signal. PID: 449 SIG: 3
I/dalvikvm(  449): threadid=7: reacting to signal 3
I/dalvikvm(  449): Wrote stack trace to '/data/anr/traces.txt'
V/DumpStateReceiver(   52): Running: /system/bin/dumpcrash
I/DumpStateReceiver(   52): Finished: 1831 bytes read; status 0
I/DumpStateReceiver(   52): Added state dump to 1 crashes
W/ActivityManager(   52): Launch timeout has expired, giving up wake
lock!
W/ActivityManager(   52): Activity idle timeout for HistoryRecord
{434ef860 {com.
google.android.googleapps/
com.google.android.googleapps.RunSetupWizardActivity}}

D/dalvikvm(  181): GC freed 194 objects / 10064 bytes in 170ms
D/dalvikvm(  269): GC freed 3306 objects / 189336 bytes in 204ms


--~--~---------~--~----~------------~-------~--~----~

2. Unable to run develop Android with Eclipse

Hi all,
Please bear with me and help me out. I have followed all the steps
required to develop Android applications on my Windows..using Eclipse
3.4 (Ganymede).
- Installed Java SDK 5.0
- Downloaded Eclipse 3.4
- Downloaded Android SDK 1.1_r1
- Got the ADT plugin for Eclipse by Help>Software Update >
http://dl-ssl.google.com/android/eclipse/
- Restarted Eclipse...
**Problem**
- Go to Windows > Preferences > I should see Android in the left panel
so I can set the paths.
For some reason I do not see this....I dont see Android in the left
panel...

I have tried everything....but cant figure it out. Initially, I
thought this could be because the Envoirment variables are not set
correctly. In these forums its suggested to set the Path variable to
point to Android-sdk-windows-1.1_r1/tools. When I do this and try to
start Eclipse...it says "cannot find java virtual machine" so then I
have set the "path" variable as such
Path: "C:\Windows\System32\;C:\Documents and Settings\Administrator\My
Documents\Dev\android-sdk-windows-1.1_r1\tools"

Still I can't see Android in the Eclipse preferences...
please suggest what can be done to fix this...Thank you so much in
advance...

Thanks,
Azam
--~--~---------~--~----~------------~-------~--~----~

3. RemoteViews should support EditText

4. android over beagleboard intialization stucks

5. How to apply LOCAL_AAPT_FLAGS to eclipse project?

6. ALSA setprop values

7. TrackBall an event states: is there always a ACTION_DOWN before ACTION_MOVE