Problem with ADT for Eclipse

by rben » Sat, 16 Jan 2010 09:54:36 GMT


Sponsored Links
 After deleting a phone I had created in the emulator, I can no longer
get my Android application to run from Eclipse. Usually I can tease
out a way to fix stuff from error messages, but this time I'm stumped.
When I try to run I get the following error:

java.lang.NullPointerException
        at
com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController.launch
(Unknown Source)
        at
com.android.ide.eclipse.adt.internal.launch.LaunchConfigDelegate.doLaunch
(Unknown Source)
        at
com.android.ide.eclipse.adt.internal.launch.LaunchConfigDelegate.launch
(Unknown Source)
        at org.eclipse.debug.internal.core.LaunchConfiguration.launch
(LaunchConfiguration.java:853)
        at org.eclipse.debug.internal.core.LaunchConfiguration.launch
(LaunchConfiguration.java:703)
        at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch
(DebugUIPlugin.java:866)
        at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run
(DebugUIPlugin.java:1069)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Any suggestions? This has brought my work to a halt.



Problem with ADT for Eclipse

by rben » Sat, 16 Jan 2010 11:56:38 GMT


 Ok, I finally got it running, by creating a new project and importing
all the source. More
fun than I deserve.



> Any suggestions? This has brought my work to a halt.


Sponsored Links


Other Threads

1. How to read XML file from sdcard and parse it?

InputStream obj_is = null;
Document obj_doc = null;
DocumentBuilderFactory doc_build_fact = null;
DocumentBuilder doc_builder = null;
obj_is = new FileInputStream("/sdcard/xmlfile.xml");
doc_build_fact = DocumentBuilderFactory.newInstance();
doc_builder = doc_build_fact.newDocumentBuilder();

obj_doc = doc_builder.parse(obj_is);

 NodeList obj_nod_list = null;
  if(null != obj_doc)
    {
org.w3c.dom.Element feed =  obj_doc.getDocumentElement();
obj_nod_list = feed.getElementsByTagName("tag name u want to parse");
    }


to get the no of elements founded :  obj_nod_list.getLength();





> 

2. My activity runs onCreate() every time and process do not disappear

Hello all:
I have a activity always runs onCreate() after I come back to previous
activity.
I think my emulator needs memory, so it killed my activity.
But I use eclipse DDMS tool to watch my process, it still there with
the same process id.
This really confuses me. Could anyone explain why?

Here is the link describe activity life cycle, always kill process
before running onCreate()
http://developer.android.com/reference/android/app/Activity.html#ActivityLifecycle

Sorry that my source code is too big, so it is hard to post here.

3. What is the defalt screensize of emulator.

4. Intent filter matching problem

5. Does emulator 1.6/2.0 supports bluetooth and WIFI?

6. Two touchscreen drivers in sapphire and trout phone

7. Segfault in what looks like WebView