Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Devaraj » Tue, 09 Jun 2009 12:14:16 GMT


Sponsored Links
 Hi All,

I have added few prints in the pvmp4ffrecognizer module source files.
when I ran a .mp4 file playback use case and  collected the traces.
I could not find the traces that I have added.
I strongly doubt that during the .mp4 file playback none of the
functions from the pvmp4ffrecognizer module is getting called.
I am using an android media player application to run the .mp4 file.
Is my understanding correct?
If so, without executing the mp4 recognizer how is it able to play
the .mp4 file?

Thanks and Regards,
-Devaraj
--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Freepine » Tue, 09 Jun 2009 12:26:38 GMT


 How did you add the logs into mp4 recognizer? By printf? Or using android
marco(e.g LOGE) directly?If you were using PV logging mechnism, did you get
a logger object first?
e.g.
iLogger = PVLogger::GetLoggerObject("PVPlayerEngine");

It would be helpful if you pasted your code snippet.





--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Dev » Tue, 09 Jun 2009 12:39:03 GMT


 Hi,

I have added the logs using android macros LOGV(""); directly.

Thanks and Regards,
-Devaraj






--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Freepine » Tue, 09 Jun 2009 12:45:30 GMT


 #define LOG_NDEBUG 0
is required to enable LOGV.







--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Ravi » Tue, 09 Jun 2009 16:24:49 GMT


 Which test application are you using? (i) pvplayer_engine_test, or
(ii) a mediaplayer test, or (iii) your own test app?

(i) As I mentioned earlier, this test app. guesses the format type
based on the file extension. So, a .mp4 file is set the format type
accordingly. If you want to force the "recognition", rename the file
extension to .xyz.

(ii) If you have proper logs, it should definitely show up.

(iii) Good luck.

-Ravi






--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Devaraj » Wed, 10 Jun 2009 05:48:26 GMT


 Thanks to both Freepine and Ravi for ur suggestions.
I am getting the logs from the mp4 recognizer plugin.

I have one more query, I have both AVI and MP4 recognizer plugins in
place.
when I tried playing .avi and .mp4 files it is picking up the MP4
recognizer plugin in both the cases.
It is not picking up .avi recognizer plugin when I play the .avi file.
Why is this so? Anything that I need to change in my code so that it
picks up the avi recognizer plugin while playing the .avi file.

Thanks again.









--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Freepine » Thu, 11 Jun 2009 12:12:29 GMT


 If you don't want to modify mp4 recognizer plugin to ignore avi files,
perhaps you can try to register avi recognizer plugin before mp4 recognizer.
(e.g. put avi on top of mp4 items in pvplayer.cfg file).








--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Dev » Thu, 11 Jun 2009 12:31:51 GMT


  tried that option. I had put avi recognizer before the mp4 recognizer in
pvplayer.cfg but the results seems to the same. It still picks up mp4
recognizer for .avi file playback.


On Thu, Jun 11, 2009 at 5:42 PM, Freepine <freep...@gmail.com> wrote:


--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Freepine » Thu, 11 Jun 2009 13:14:07 GMT


 o did your recognizer get executed before mp4 recognizer?

On Thu, Jun 11, 2009 at 8:31 PM, Dev <devara...@gmail.com> wrote:


--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Devaraj » Fri, 12 Jun 2009 05:12:57 GMT


 elow two lines in pvplayer.cfg indicates that there are two different
interface ids for the same libopencore_mp4localreg.so

(0x1d4769f0,0xca0c,0x11dc,0x95,0xff,0x08,0x00,0x20,0x0c,0x9a,
0x66),"libopencore_mp4localreg.so"
(0x6d3413a0,0xca0c,0x11dc,0x95,0xff,0x08,0x00,0x20,0x0c,0x9a,
0x66),"libopencore_mp4localreg.so"

why do we have difference interface ids for the same
libopencore_mp4localreg.so in the pvplayer.cfg?



On Jun 11, 6:13pm, Freepine <freep...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Devaraj » Fri, 12 Jun 2009 05:54:00 GMT


  got to know this. One is for the node and the other is for the
recognizer.

Now it is able to pickup the avi recognizer plugin during avi file
playback.



On Jun 12, 10:12am, Devaraj <devara...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by Devaraj » Mon, 15 Jun 2009 07:11:22 GMT


 s we know .avi file playback is not supported in the current OpenCore
code base but we have the AVI file parser module source code. So, I
just wanted to know whether the AVI file parser code that is present
in the opencore is complete and working fine?


On Jun 12, 10:53am, Devaraj <devara...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Recognizer plugins are not getting executed when I run .mp4 file playback use case

by leon » Sun, 02 Aug 2009 21:45:10 GMT


 ave anybody finished the avi's support?
If yes, could you share your solution to us? Thanks

Regards
Leon

On 65 31 Devaraj <devara...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Uid mismatch

It seems that the install failure of a particular apk may be
attributed to
mismatch uids. What causes such mismatches and is it possible to
correct them without losing the user data - particularly in this case
where only a certain app apk does that but the rest are fine. Where
do these uids get stored?

This is the message:
Package com.CP_16 has mismatched uid: 10048 on disk, 10045 in settings

If I create a new apk using the source from the apk that fails I still
get
the same message with a different uid:
Package com.WebCP_16 has mismatched uid: 10042 on disk, 10044 in
settings

I will appreciate any hints on this or where to look for some.

Thanks

-- 

2. how can I simultaneously download files

Hello!
I'm writing app for android device, which is simple download manager.
I want to download 2/3 files simultaneously, but I'm really confused
how to do it.

I don't want use async task because it could be killed and I want to
run download in background.
So I think I should use IntentService, but I can run only one
IntentService at time.
I have two ideas, how to do it, but I don't know which one to choose.
First is to run intentservice inside AsyncTask and second is to run
thread inside intentservice.
But either ways I don't know how to inform IntentService about new
file to download, while another download is already running.
Or maybe I should use traditional 'implement Runnable'?

Thanks for any help :)

-- 

3. Question on layouts

4. Questions about the Platform SDK

5. emulator spikes pulseAudio on Linux?

6. using setIcon to specify icon in assets w/o XML?

7. can you set dns-server in avd config.ini?