openCore and run_pe_test unit tests

by RCP2278 » Tue, 10 Feb 2009 20:20:53 GMT


Sponsored Links
 Hi,

Question about the run_pe_test command when running the unit tests for
openCore.

I'm trying to understand how the Media I/O works in the openCore
engine, in particular the video output.  I know that in the unit
tests, the output are being sent to a file (both audio and video)
instead of a device player.  When running the streaming tests
(specifically -test 201 201), I noticed that it is generating two .dat
files, one for audio and one for video.  When I attempted to open
these files through a native player (I'm using VLC and in Ubuntu Totem
Movie Player 2.22.1), the audio dat file is being played back
successfully but not the video dat file.  Can someone explain why this
is the case?  Should I be able to playback the generated .dat file if
I open it in a media player?  I've observed the same behavior if I run
the File Format Test Cases as well.

FYI: I ran the test cases for Progressive Streaming but it seems that
is failing (-test 150 161)

Any help or input is appreciated.  Thanks.

-R
--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by RCP2278 » Tue, 10 Feb 2009 23:20:09 GMT


 Nevermind, I found a yuv viewer to play the raw video dat file and
verified that I can play it back.  Ignore my previous post.  Thanks.

R




--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


openCore and run_pe_test unit tests

by raj.10788 » Tue, 07 Apr 2009 11:38:44 GMT


 Hi RCP2278,

I am trying to execute the open core unit test cases. But am getting
errors. Can you please tell me the procedure how to execute the test
cases. I don have any idea about this frame work.SO am trying to
understand the functioning of that one. So can you please tell me the
clear idea how to start with this test cases.

I am waiting for your pointers and guidence

Thanks in advance.

rgds,
raj




--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by Renuka V » Tue, 07 Apr 2009 11:51:55 GMT


 Hi RCP,

I'm trying to run the test case 201 . When I try running it from the
emulator both my .dat files are having 0 bytes.

when I try running on the host PC without Android then I find that the .dat
files are not even getting created.Please tell where I'll find it.

Please help me on this, as it is very very necessary for me to fix it.

-renu

--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by Eric Chen » Wed, 08 Apr 2009 00:05:41 GMT


 You probably can't dude







--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by rk » Wed, 08 Apr 2009 05:58:12 GMT


 Hi Eric,

What you mean by *You probably can't dude*??
Did you mean that I can't execute that test cases or you mean that I can't
understand that test cases.


regards,
raj








--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by Gurpreet Sachdeva » Wed, 08 Apr 2009 06:27:42 GMT


 Did you specify any source URL for the test case? Could you please post the
output logs when the test case executes?

Gurpreet






-- 
Thanks and Regards,
Gurpreet Singh

--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by raj.10788 » Wed, 08 Apr 2009 07:43:07 GMT


 Hi Gurpreet,

Can you able to run the opencore test cases. Can you please tell me
the steps to do that.

When I try the steps given in the quick_start.txt file,am getting
error. Can you please tel me the steps.

On Apr 8, 11:27am, Gurpreet Sachdeva <gurpreet.sachd...@gmail.com>



--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by Girish » Wed, 08 Apr 2009 12:00:12 GMT


 Paste the logs so tht ppl can tell about the probelm. Otherwise
difficult to imagine something which is happening in your case,

Regards
Girish





--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by raj.10788 » Thu, 09 Apr 2009 12:48:33 GMT


 Hi RCP,

I am facing th e problem in the playback of the dat file. I executed
the test case 33. Then I got two dat files. when I try to run it on
mediaplayer. It is not running.

So if you know the solution for this one can you please tell me the
solution.


thanks
raj






--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by raj.10788 » Thu, 09 Apr 2009 13:00:03 GMT


 Hi All,

I build the whole Android source and replaed my SDK built images with
my custom bilt images. Now I can able to run the test cases.

But I can;t able to play the dat files in the Media Player.


Thanks
raj





--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by sonal gupta » Fri, 10 Apr 2009 06:34:14 GMT


 DId u face any issues in getting the dump in .dat files ?
because i get only the header in the .dat files........ and there is no
output frame dump ..

did u face any such issues ? if yes, could you please help me on this?









--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by sonal » Fri, 10 Apr 2009 10:06:42 GMT


 I could finally figure out this issue :)

here is the reason :
Issue was due to time stamps. Output Node was finding the time stamp
to be LATE always in checkMediaTimeStamp ,
and discarding the data, without sending it further to sendMediaData.

After fixing this media time stamp LATE issue, I am able to see the
dump :)

Regards,
Sonal









--~--~---------~--~----~------------~-------~--~----~



openCore and run_pe_test unit tests

by Renuka V » Mon, 13 Apr 2009 04:59:00 GMT


 Hi All,

I'm trying to run the streaming test case 201 /851 and I'm not able to able
to get any dumps (i.e ".dat" files are showing 0 bytes) when I run the test
case on the emulator.

When I try running it on the host PC, the ".dat" files are not getting
created in the current directory.

Can anyone please help me or atleast let me know if there are any issues
with the streaming code.

Thanks & Regards,
Renuka.V

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. WebView.loadData(), encoding? missing chars?

this code,
         ...
         s = "\u02c8\u0254\u0279\u0292\u0259";
         mWebView.loadDataWithBaseURL("fake://", s, "text/html", 
"utf-8", "about:blank");

results in garbage chars in the web view,



in the de{*filter*}. i actually read the string from somewhere else using 
utf-8 encoding, so it must be a utf-8 encoded string.

printed to the terminal, the string looks correct.



the string

\u00e6\u00f8\u00e5

passed to the webview renders the correctly. i'm pretty confused about 
what's going on. it appears that i am correctly passing the string to 
the webview as the second string renders correctly. could the engine 
behind the webview be missing a mapping for some utf-8 characters? i'm 
not even sure if that question makes sense.

and ideas are appreciated.

-- 

-- 

2. Upgradint ADT plugin in Eclipse problem

Hello all,

I have just updated my ADT plugin in Eclipse Ganymede to latest
version of Android SDK. But, after having downloaded the updates,
applied changes, restarted Eclipse, the Android SDK no longer loads.
The Android project option in New Project disappeared. It is the
second time that happens to me. Every time that I update the ADT
plugin, it no longer loads in Eclipse.

I also noticed the same issue after having tried to also install the
plugin for Blackberry development. After the install, all Android
related features disappear. When I try to reinstall the Android DDMS
and Android development tools again, it says it is already installed.

Is there an easy way to resolve the issue without having to reinstall
everything again from scratch?

I run Windows Vista Ultimate, Eclipse Ganymede, if that can help.

Stpane

-- 

3. TabActivity crash

4. how to capture key events with a window-less activity

5. How can I enable the voice recognition on android phone?

6. Can other applications use the share function of "Facebook for Android"?

7. Saving service killing without "startForeground"