froyo build error

by zhuyang220 » Wed, 20 Oct 2010 21:57:23 GMT


Sponsored Links
 Hi,

     I just started to build the aosp, I got the error below:

 #make -j4
============================================
PLATFORM_VERSION_CODENAME=AOSP
PLATFORM_VERSION=AOSP
TARGET_PRODUCT=dkb
TARGET_BUILD_VARIANT=eng
TARGET_SIMULATOR=
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
HOST_ARCH=x86
HOST_OS=linux
HOST_BUILD_TYPE=release
BUILD_ID=OPENMASTER

.............
No private recovery resources for TARGET_DEVICE dkb
host Executable: acp (out/host/linux-x86/obj/EXECUTABLES/
acp_intermediates/acp)
No rule to make target `out/target/common/obj/JAVA_LIBRARIES/
core_intermediates/javalib.jar', needed by `out/target/common/docs/api-
stubs-timestamp'.  Stop.
make: *** Waiting for unfinished jobs....

    Did anyone who face this problem? Could you give me some advices
to solve this problem?
    Thanks in advanced!

-- 



froyo build error

by Hamilton Vera » Wed, 20 Oct 2010 23:11:45 GMT


 Check if you are using the proper CROSS_COMPILE settings.

[]'s

Hamilton Vera






-- 
Hamilton Vera
int Administrator (char Network[],char ComputationalSystems[])
 http://hvera.wordpress.com 

-- 


Sponsored Links


Froyo Build Error

by Prabagaran Thangavel » Sun, 15 May 2011 00:40:47 GMT


 Hi all,
        I have a problem trying to build the froyo source code and got the
build error.
Kindly let me know how to solve the issue.
Following is the error message

*In file included from external/qemu/android/skin/window.c:19:0:*
*prebuilt/linux-x86/sdl/include/SDL/SDL_syswm.h:55:22: fatal error:
X11/Xlib.h: No such file or directory*
*compilation terminated.*
*make: ***
[out/host/linux-x86/obj/EXECUTABLES/emulator_intermediates/android/skin/window.o]
Error 1*
*make: *** Waiting for unfinished jobs....*

With Regards,
Prabagaran.

-- 



Re: Froyo Build Error

by Name Less, the Jedi » Sun, 15 May 2011 05:01:42 GMT


 2011/5/14 Prabagaran Thangavel <prabagara...@gmail.com>


I believe that you are missing X11 developement package. On Debian (and
Ubuntu probably) it's called libx11-dev.
Have a look at  http://s.android.com/source/initializing.html for list of all 
packages that are needed to build AOSP


-- 
Name Less, the Jedi < http://www.nl-j.org/> ;
Just a friendly Jedi Knight

-- 



Other Threads

1. Transparent background overlay of SurfaceView broken on 1.5

Hi,
        Ya, It is true..Transparency is not working with r1 patch, You can
take Android new patch( r2 ).. it will give proper response..






-- 
Thank & Regards
Peeyush Varshney

--~--~---------~--~----~------------~-------~--~----~

2. when I start to compile the Launcher module, lots of erros occurred.

Launcher cannot compile against the SDK, sorry.






-- 
Romain Guy
Android framework engineer
romain...@android.com

Note: please don't send private questions to me, as I don't have time
to provide private support.  All such questions should be posted on
public forums, where I and others can see and answer them

--~--~---------~--~----~------------~-------~--~----~

3. How can i implement search functionality in GoogleMaps while using SDK 1.5.

4. my app crashes when switching to landscape mode

5. Q re Android Programming Tutorials a.M Murphy

6. when I start to compile the Launcher module, lots of erros occurred.

7. How can i implement search function of GoogleMaps on SDK 1.5.