Animated GIFs?

by Eric Hekler » Tue, 20 Apr 2010 13:08:25 GMT

Sponsored Links
 Hi, all.

    We are doing some prototyping for an Android app and we wanted to use
Animated GIFs via webpages to get a sense of animation.  Unfortunately, we
have found that we can't do that on the Android's browser (or Opera for that
matter).  I've read some posting saying that this might get fixed but there
were never any specific dates.  Does anyone have some news on when we might
be able to use Animated GIFs in webpages?   If not, does anyone have any
suggestions on good ways to develop quick animated visual prototypes of apps
for Android?  In particular, our design folks (who are handling the visual
stuff) know HTML, Javascript, J-query but don't know Java and we would
prefer to NOT have them learn another language, if possible as this is
really just for rapid prototyping.

   Any help would be most appreciated!


Eric Hekler, Ph.D.
Post Doctoral Research Fellow
Stanford Prevention Research Center
Medical School Office Building: Mail Code 5411
251 Campus Drive
Stanford, CA 94305-5411
Office # (650) 721-2516
Fax:  650-725-6247


Animated GIFs?

by Anonymous Anonymous » Tue, 20 Apr 2010 13:31:15 GMT

 As per issue tracker, this will be fixed in FroYo and will work on high
memory devices.


Sponsored Links

Other Threads

1. developing on a physical device

Hi all,
         I have a android based device on which I am trying to run a
simple hello world application, but I don't see the device listed
using : adb devices.

My setup is Eclipse 3.5, ADT 0.9.5, Android SDK 1.6, Debian 5.0.5
(lenny) with SMP kernel.

I have already tried the various options listed on

The usb debugging is enabled on the device and I have already tried
setting up /etc/udev/rules.d/51-android.rules with the following

SUBSYSTEM=="usb", SYSFS{idVendor}=="0955", MODE="0666"

dmesg shows the following output:

[155544.908038] usb 7-2: new high speed USB device using ehci_hcd and
address 8
[155545.057192] usb 7-2: New USB device found, idVendor=0955,
[155545.057194] usb 7-2: New USB device strings: Mfr=1, Product=2,
[155545.057196] usb 7-2: Product: ADB Composite Device
[155545.057198] usb 7-2: Manufacturer: NVIDIA Corporation
[155545.057199] usb 7-2: SerialNumber: 0123456789ABCDEF
[155545.057280] usb 7-2: configuration #1 chosen from 1 choice
[155545.074121] scsi10 : SCSI emulation for USB Mass Storage devices
[155545.074328] usb-storage: device found at 8
[155545.074329] usb-storage: waiting for device to settle before
[155560.072610] usb-storage: device scan complete
[155560.073098] scsi 10:0:0:0: Direct-Access     <NULL>
<NULL>           0000 PQ: 0 ANSI: 2
[155560.073455] sd 10:0:0:0: Attached scsi generic sg2 type 0
[155560.082069] sd 10:0:0:0: [sdb] Attached SCSI removable disk

Has anyone tried running an android application with Debian Lenny
host? Please suggest if I need to make any changes to my setup.

Thanks in advance,


2. Emulator on Linux 10 times slower than on Windows

Hi there,

I know that many people are complaining about slow emulator
performance, and mostly it can't be helped because of slow hardware
and the fact that emulators somehow have to be slow by definition
because of the way they work. But something really puzzles me:

I'm using a dual boot configuration with Windows XP and Ubuntu 9.04.
On XP, the emualtor is somehow slower than a real G1 device, but it's
completely ok.

But on Ubuntu, the emulator is unusable slow. Note that other programs
run just fine under my ubuntu. I have no exact measurements, but I
think the emulator about 10 times slower than on Windows. Installing a
small app takes more than 2 minutes, starting an app sometimes takes
over 2 minutes, returning to the home screen takes up to 40 seconds,
and there is not a single click I can do that takes less than 2
seconds to trigger some kind of reaction. I get around 2 fps at most,
no matter what I do.

Both systems (of course) use the same hardware, and on both I'm using
SDK 1.6 with a 1.5 AVD without google additions, and the very same app
that I'm developing.

I used to have a very old Graphics card that I had to access through
plain old VESA drivers on both XP and Ubuntu.
Now I'm on a new hardware which uses a proper driver to access the
graphics hardware, but the emulator on Ubuntu is still as slow as
before, so I think this is not the bottleneck.

Also, I noticed that under heavy usage of the emulator, the usage of
my real CPU never went above 30%.

Is there any explanation for this slowness on Ubuntu? Or even a way to
further investigate where the bottleneck might be?


3. Android build in email client

4. G1 dream android 1.5 , where is telnetd

5. how to get header in Listview without scrolling

6. Custom menu items

7. Knowing when a scroll/fling is done.