SurfaceFlinger issues on X200

by gowtham gowda » Sun, 12 Apr 2009 03:17:48 GMT


Sponsored Links
  am trying to port android to a lenovo X200 laptop. I am running into
an issue with SurfaceFlinger. How do i get past this?

This is a partial dmesg output. I can post the full file is that will
be helpful in fixing this issue.

Can someone help me? please.


<3>[ 8.152864] init: /init.rc: 111: invalid option 'enabled'
<7>[ 8.198459] power_supply AC: uevent
<7>[ 8.198461] power_supply AC: POWER_SUPPLY_NAME=AC
<7>[ 8.198465] power_supply AC: Static prop TYPE=Mains
<7>[ 8.198467] power_supply AC: 1 dynamic props
<7>[ 8.198469] power_supply AC: prop ONLINE=1
<7>[ 8.198530] power_supply BAT0: uevent
<7>[ 8.198532] power_supply BAT0: POWER_SUPPLY_NAME=BAT0
<7>[ 8.198535] power_supply BAT0: Static prop TYPE=Battery
<7>[ 8.198537] power_supply BAT0: 12 dynamic props
<7>[ 8.204312] power_supply BAT0: prop STATUS=Full
<7>[ 8.204315] power_supply BAT0: prop PRESENT=1
<7>[ 8.204317] power_supply BAT0: prop TECHNOLOGY=Li-ion
<7>[ 8.204319] power_supply BAT0: prop VOLTAGE_MIN_DESIGN=10800000
<7>[ 8.204321] power_supply BAT0: prop VOLTAGE_NOW=12502000
<7>[ 8.204323] power_supply BAT0: prop CURRENT_NOW=0
<7>[ 8.204326] power_supply BAT0: prop ENERGY_FULL_DESIGN=84240000
<7>[ 8.204328] power_supply BAT0: prop ENERGY_FULL=78250000
<7>[ 8.204330] power_supply BAT0: prop ENERGY_NOW=77840000
<7>[ 8.204332] power_supply BAT0: prop MODEL_NAME=42T4542
<7>[ 8.204334] power_supply BAT0: prop MANUFACTURER=Panasonic
<7>[ 8.204336] power_supply BAT0: prop SERIAL_NUMBER= 758
<3>[ 8.220624] init: cannot open '/initlogo.rle'
<6>[ 7.861334] kjournald starting. Commit interval 5 seconds
<6>[ 8.408902] EXT3 FS on sda6, internal journal
<6>[ 8.408902] EXT3-fs: mounted filesystem with ordered data mode.
<6>[ 8.046208] kjournald starting. Commit interval 5 seconds
<6>[ 8.427380] EXT3 FS on sda8, internal journal
<6>[ 8.427770] EXT3-fs: mounted filesystem with ordered data mode.
<6>[ 8.059823] kjournald starting. Commit interval 5 seconds
<6>[ 8.629414] EXT3 FS on sda5, internal journal
<6>[ 8.629804] EXT3-fs: mounted filesystem with ordered data mode.
<6>[ 17.737569] warning: `app_process' uses 32-bit capabilities
(legacy support in use)
<6>[ 17.485662] SurfaceFlinger[2028]: segfault at 38 ip 80111049 sp
b5baafec error 4 in libc.so[80100000+4b000]
<6>[ 17.819234] android_power: wakeup (0->0) at 18616085691
(2009-04-11 14:48:18.297510927 UTC)
<6>[ 17.911065] SurfaceFlinger[2037]: segfault at 38 ip 80111049 sp
9e038fec error 4 in libc.so[80100000+4b000]
<6>[ 17.586014] android_power: wakeup (0->0) at 18714072098
(2009-04-11 14:48:18.395497264 UTC)
<6>[ 23.007848] SurfaceFlinger[2047]: segfault at 38 ip 80111049 sp
9df5afec error 4 in libc.so[80100000+4b000]
<6>[ 22.690556] android_power: wakeup (0->0) at 23817699573
(2009-04-11 14:48:23.499124808 UTC)
<6>[ 28.109087] SurfaceFlinger[2057]: segfault at 38 ip 80111049 sp
b5c69fec error 4 in libc.so[80100000+4b000]
<6>[ 27.798946] android_power: wakeup (0->0) at 28926174126
(2009-04-11 14:48:28.607599361 UTC)
<6>[ 32.902927] SurfaceFlinger[2066]: segfault at 38 ip 80111049 sp
9e020fec error 4



Other Threads

1. Support for newer kernel versions

Are there plans to move the android development to a newer Linux
kernel such as 2.6.31, etc. Maybe there a road map document somewhere
that I missed? Thanks!

---chuck

--~--~---------~--~----~------------~-------~--~----~
unsubscribe: android-kernel+unsubscr...@googlegroups.com
website: 

2. help me:Compile the android kernel for the Emulator

My platform:   CentOS 5.3
compilor:       arm-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-
gnu.tar.bz2
android sdk 1.5  jdk1.6
elipse 3.4
directory:
 /home/nature/Software/arm-2009q1(untar the packege directory)
/home/nature/Program/common
/home/nature/Software/android-sdk-linux_x86-1.5_r1


1,  get the kernel:  git clone git://android.git.kernel.org/kernel/common.git
3, yum update
2, I check the tools according the kernel/Documentation/Changes
install the missed software.
3, $emulator -avd myavd1.5(my avd name is myavd1.5)   //running the
emulator
   $cd /home/nature/Program/common
   $adb pull /proc/config.gz .
   $gunzip config.gz
  $mv config  .config
  $gedit Makefile

  change two points:

1>   CROSS_COMPILE = /home/nature/Software/arm-2009q1/arm-none-linux-
gnueabi-


2>    LDFLAGS_BUILD_ID =
#LDFLAGS_BUILD_ID = $(patsubst -Wl$(comma)%,%,\
#                             $(call ld-option, -Wl$(comma)--build-id,))


exit the gedit back in the old terminal.
$export PATH=$PATH:/home/nature/Software/arm-2009q1/bin
$export ARCH=arm
$make oldconfig
List some options. All are default.
$make
Produce the zImage in the common/arch/arm/boot/
In the compile, no error output.
$emulator @myavd1.5 -kernel /home/nature/Program/common/arch/arm/boot/
zImage

Nothing output.

In the another terminal
#ps -a
  PID TTY          TIME CMD
 5242 pts/1    00:00:00 su
 5246 pts/1    00:00:00 bash
20676 pts/2    00:00:04 emulator
20681 pts/2    00:00:00 java <defunct>
20697 pts/1    00:00:00 ps

I don't know why is it?
who can help me?
--~--~---------~--~----~------------~-------~--~----~
unsubscribe: android-kernel+unsubscr...@googlegroups.com
website: 

3. Help me: Compile 2.6.29 for Htc Hero

4. activity leaked a window

5. Chosse the connection interface before sending request?

6. Auto answer calls and hangup programmetically

7. ActivityManager.restartPackage() and syncing - Sync on StatusBar remains after killing