MediaPlayer not running - just blank screen

by Nithin » Thu, 05 Mar 2009 15:46:00 GMT


Sponsored Links
 hi,

I tried a simple mediaplayer application, just to run a .3gp file.
First, i put the .3gp file in "Raw" folder and tried to run, but
nothing is displaying, just blank screen only.... please guide me,
where i am going wrong. I dont have any xml file, is it needed ??

heres the code, which i am trying

import android.app.Activity;
import android.media.MediaPlayer;
import android.os.Bundle;

public class MonsterEntry extends Activity {

        public void onCreate(Bundle savedInstanceState) {
                super.onCreate(savedInstanceState);
                MediaPlayer mediaplayer = MediaPlayer.create(this, 
R.raw.monster);
                mediaplayer.start();
        }
}

Thanks
Nithin
--~--~---------~--~----~------------~-------~--~----~



MediaPlayer not running - just blank screen

by dillirao malipeddi » Thu, 05 Mar 2009 15:56:00 GMT


 you must set parameters for playing video
see api demos - >examples media ->  video demo player






-- 
Dilli Rao. M
ARIJASOFT
+91 - 9703073540

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


MediaPlayer not running - just blank screen

by Dave Sparks » Thu, 05 Mar 2009 15:58:11 GMT


 You need to tell the mediaplayer where to display the video with
setDisplaySurface(). Check out the media demo apps on
developer.android.com.



--~--~---------~--~----~------------~-------~--~----~



MediaPlayer not running - just blank screen

by nithin » Thu, 05 Mar 2009 17:44:41 GMT


 hanks for your reply, but still not working.. Now i am trying with
this code...



import android.app.Activity;
import android.media.MediaPlayer;
import android.os.Bundle;
import android.util.Log;
import android.view.SurfaceHolder;
import android.view.SurfaceView;
import android.widget.MediaController.MediaPlayerControl;

public class Monster extends Activity implements
SurfaceHolder.Callback, MediaPlayer.OnPreparedListener {

SurfaceView mPreview;
SurfaceHolder holder;
MediaPlayer mediaplayer;
int mVideoWidth,mVideoHeight;

public void onCreate(Bundle savedInstanceState) {
super.onCreate(savedInstanceState);
setContentView(R.layout.bushentry);
mPreview = (SurfaceView)findViewById(R.id.surface);
holder = mPreview.getHolder();
holder.addCallback(this);
holder.setType(SurfaceHolder.SURFACE_TYPE_PUSH_BUFFERS);
mediaplayer = MediaPlayer.create(this, R.raw.monster);
mediaplayer.start();
mediaplayer.setDisplay(holder);
mediaplayer.setOnPreparedListener(this);
}
public void surfaceChanged(SurfaceHolder holder, int format, int
width,
int height) {

}
public void surfaceCreated(SurfaceHolder holder1) {
mVideoWidth = mediaplayer.getVideoWidth();
mVideoHeight = mediaplayer.getVideoHeight();
if (mVideoWidth != 0 && mVideoHeight != 0) {
holder.setFixedSize(mVideoWidth, mVideoHeight);
mediaplayer.start();
}
}
public void surfaceDestroyed(SurfaceHolder holder) {
}

public void onPrepared(MediaPlayer mp) {
mVideoWidth = mediaplayer.getVideoWidth();
mVideoHeight = mediaplayer.getVideoHeight();
if (mVideoWidth != 0 && mVideoHeight != 0) {
holder.setFixedSize(mVideoWidth, mVideoHeight);
mediaplayer.start();
}
}
}


Still, the same problem, no error, but blank screen, any idea please..

Nithin


On Mar 5, 12:58pm, Dave Sparks <davidspa...@android.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



MediaPlayer not running - just blank screen

by nithin » Thu, 05 Mar 2009 18:03:46 GMT


 o, there is no error in logcat...
i put log messages every where and logcat showing all messages, but no
video is playing..

Nithin

On Mar 5, 2:48pm, dillirao malipeddi <dillir...@arijasoft.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



MediaPlayer not running - just blank screen

by nithin » Thu, 05 Mar 2009 18:18:21 GMT


 a, i saw log messages, in that, getVideoSize returning -1.......

what may be the reason for that, any idea please..


Nithin


03-05 14:59:43.072: INFO/1111(324): 111111111111111
03-05 14:59:43.113: INFO/2222222(324): 22222222222222222222
03-05 14:59:43.123: INFO/333333333333333(324): 33333333333333
03-05 14:59:43.333: INFO/444444444444(324): 4444444444444444
03-05 14:59:43.412: INFO/66666666666(324): 66666666666666666666666
03-05 14:59:43.412: ERROR/MediaPlayerService(24): getVideoSize
returned -1
03-05 14:59:43.424: ERROR/MediaPlayerService(24): getVideoSize
returned -1
03-05 14:59:43.634: INFO/55555555555555555(324):
55555555555555555555555555
03-05 14:59:43.644: ERROR/MediaPlayerService(24): getVideoSize
returned -1
03-05 14:59:43.654: ERROR/MediaPlayerService(24): getVideoSize
returned -1
03-05 14:59:43.714: INFO/ActivityManager(46): Displayed activity
com.monster/.Monster: 735 ms
03-05 14:59:48.863: DEBUG/dalvikvm(94): GC freed 1037 objects / 53600
bytes in 68ms
03-05 14:59:51.931: WARN/AudioFlinger(24): write blocked for 157 msecs
03-05 14:59:53.465: WARN/AudioFlinger(24): write blocked for 146 msecs
03-05 14:59:54.915: WARN/AudioFlinger(24): write blocked for 259 msecs
03-05 14:59:55.094: WARN/AudioFlinger(24): write blocked for 130 msecs
03-05 14:59:55.190: WARN/AudioFlinger(24): write blocked for 58 msecs
03-05 14:59:55.449: WARN/AudioFlinger(24): write blocked for 96 msecs
03-05 14:59:56.705: WARN/AudioFlinger(24): write blocked for 75 msecs
03-05 15:05:42.232: DEBUG/dalvikvm(88): GC freed 9596 objects / 538312
bytes in 73ms
03-05 15:21:10.564: DEBUG/dalvikvm(88): GC freed 9289 objects / 524248
bytes in 90ms


On Mar 5, 3:03pm, nithin <nithin.war...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



MediaPlayer not running - just blank screen

by nithin » Fri, 06 Mar 2009 15:38:21 GMT


 hanks marco, at last got it...

thanks for your valuable input..

Nithin

On Mar 5, 10:02pm, Marco Nelissen <marc...@android.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. my activity cannot return result.

All,



I created an activity which has one TabHost. I added three tabs
using mTabHost.addTab. Every tab will launch an activity(activity A,
activity B, activity C). In activity A, it will call
startActivityForResult to start activity A1. The issue is activity A
cannot get any result after A1 finish.

What is the reason? How should I do if I want to get return value?
thanks.

-- 

2. API Documentation Bug (LayoutInflater)

Hello,

It's a small typo, but an "(" is missing after the "getSystemService"
in the LayoutInflater API page example (http://developer.android.com/
reference/android/view/LayoutInflater.html).

I have noticed several small little mistakes like this in the past. Is
this the best place to report them or is somewhere else better
suited?

Thank you,
Len

-- 

3. remote file storing application

4. openssl build error "Error: bad instruction"

5. Classes on Developing Android apps

6. G2 or Nexus One for android development

7. Java Media Library