Is it necessary to disable C++ exception handling when interfacing with android?

by Elvis Dowson » Wed, 24 Jun 2009 21:04:01 GMT

Sponsored Links
      is there any reason for disabling exception handling in library
code, such as ustl-1.0?

For example, ustl/uexception.cpp line 60

/// Writes the exception as text into stream \p os.
void exception::text_write (ostringstream& os) const
    try {
        string buf;
        info (buf);
        os << buf;
    } catch (...) {}

Best regards,



Other Threads

1. Problem in device detection in SuSE


I am using openSUSE 10.3 (X86-64).

When I connect my ADP1 through usb and run the command "adb devices",
in the "List of devices attached", it does not show my phone.

I have tried the instructions given for Ubuntu in the developers'
If you're developing on Ubuntu Linux, you need to add a rules file:

   1. Login as root and create this file: /etc/udev/rules.d/50-

      For Gusty/Hardy, edit the file to read:
      SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"

      For Dapper, edit the file to read:
      SUBSYSTEM=="usb_device", SYSFS{idVendor}=="0bb4", MODE="0666"
   2. Now execute:
      chmod a+rx /etc/udev/rules.d/50-android.rules

But, none of the steps mentioned in 1 is helpful in this context.

Can somebody help me out to make it work under SuSE?



2. Default location of AVD files in Vista - not C:\Users\<user>\.android

I just created a new AVD and noticed the .android folder was placed at
D:\.android instead of the documented location. Then when I run the
emulator using this AVD, the emulator cannot find it and so fails to

I assume this is because I have changed the location of the standard
user folders (Desktop, Downloads, Documents etc) - i.e. right click on
the Documents folder and then click on the Location tab etc

So, for example, my desktop is stored at D:\Desktop instead of C:\Users

I've tried moving the .android folder back to the Users location with
limited success. First I had to edit the .ini file to point to the new
location. However, when starting the emulator I get an exception about
being unable to read/load the preferences. The emulator continues to
start up but never progresses beyond the Android logo screen. Oh, BTW
I'm using 1.5r2.

So, in short, the default location for when creating an AVD is not the
same as the default location used by the emulator when retrieving the

3. Releasing a Demo App from Paid App. Need to fork code? How do accomplish?

4. Problem in identifying which widget click is launching the activity?

5. GSM Modem

6. noser android comments??

7. Volume Button Broadcast?