Problems installing Eclipse with Android.

by Albion » Thu, 01 Jul 2010 09:06:48 GMT


Sponsored Links
 I've been following the tutorial at this page...
 http://www.vogella.de/articles/Android/article.html 

I had originally sent an e-mail to the author of the tutorial who
promptly told me that I shouldn't e-mail him about his tutorial, but
should ask this group instead.  Below is a copy of the e-mail I sent
him, I am hoping someone here can help.

--

I am running Windows 7 Business x64 with the latest Microsoft
updates.  Eclipse Helios Build: 20100617-1415 (IDE for Java
Developers), Android SDK r06, Android Developer Tools
0.9.7.v201005071157-36220, Java JDK 6 update 20.  All on a Quad core
E5345 with 8gig of RAM and lots and lots of hard drive space (space
isn't an issue).

1)  In Section 2.3 under "Select available packages and select the
latest version of the SDK." your tutorial tells me to select all of
the Android 2.2 packages.  What if I only want to code in Android
1.6?  Will I also need to get the 1.6 packages?  The same for 2.1?

2) In section 4.3 you tell me to open strings.xml under res/values.
When I select the resource tab for strings.xml there is nothing listed
under Resource Elements, where you say I should see "hello (String)"
and "app_name (String)".  When I try to add an element or do anything
else with the elements listed I get an error:  "An error has
occurred.  See error log for more details.
java.lang.NullPointerException."  Even when I select the strings.xml
tab next to the resource tab and try to manually change the text, for
each character I type I get the same error.  Google has turned up
nothing for that error on Eclipse with Android.  I've tried completely
removing and reinstalling Eclipse and Android SDK, making sure I
followed your tutorial for both Eclipse install and Android install
much much closer.  When I got back to the point of section 4.3 I got
the same errors.

All in all I tried reinstalling both Eclipse and Android SDK 3 times,
following your tutorial closer each time, with the same result.  Any
ideas what I may be doing wrong?

I really appreciate the tutorial and your help.  Thanks

--

-Craig

--



Problems installing Eclipse with Android.

by Frank Weiss » Thu, 01 Jul 2010 09:45:12 GMT


 Hmm. I've heard that the resources editor is buggy. Work around is to
edit the XML directly. If you really need to use the resource editor,
might I suggest fixing the code yourself and submitting to the Android
project?

--


Sponsored Links


Problems installing Eclipse with Android.

by Zigurd » Thu, 01 Jul 2010 11:38:23 GMT


 Does your question 1 refer to the step in installation where you use
the AVD and SDK Manager to install build target packages? If so, you
can choose to install all of them without using up too much space on a
big machine. If you install all of the build targets you will be sure
to be compatible with example code that is set up for various API
levels.

A null pointer exception reported in Eclipse that occurs in an Android
XML editor usually means the visual editor could not interpret or
create the XML correctly. The most common case I see that is
attempting to use a layout editor where a View class has been
subclassed and the subclass name is used in the layout - the layout
editor can't handle that. So I suspect you have encountered something
similar. Edit the XML "by hand" - switch to the xml view using the
tabs at the bottom of the editor pane - and make sure that there are
no errors in the XML file.




--



Problems installing Eclipse with Android.

by Matthew » Thu, 08 Jul 2010 02:34:29 GMT


  also get this problem.
Even just editing the xml by hand using the xml tab I get errors for
every letter I type. It does still let me save and it does compile
successfully. I'm also on Windows 7 64bit

On Jul 1, 4:38am, Zigurd <zigurd.medni...@gmail.com> wrote:

--



Problems installing Eclipse with Android.

by Indicator Veritatis » Thu, 08 Jul 2010 05:41:27 GMT


 lancing through this thread, I can see it has been a frustrating
experience for both of you. So I feel a little sheeping about asking
for more details, yet it must be done, so I have to ask: where are you
seeing these errors? More specifically, which error messages are you
referring to? The same Null Pointer Exception the OP referred to at
first, or are you referring to the little red 'x' marks the Eclipse UI
puts up whenever it THINKS you have an error?

The reason I ask is because what you so briefly describe does not
sound like the same thing the OP originally described: it sounds
rather like what I used to see all the time, that Eclipse trips over
its own two left feet trying to print error messages to the log as it
stubbornly tries to interpret the XML code I haven't finished typing
yet.

If that is what you are seeing, there are two workarounds: 1) get at
least 3G of RAM on your machine, so that Eclipse can waste cycles with
these error messages and still have some to spare or 2) turn off the
automatic build feature, so that it interprets it only when you say it
is ready to be interpreted.

Before I upgraded to 3G of RAM, I was turning the automatic build
feature on and off to get around the things that don't work right in
either state:( Sometimes, Eclipse fails to detect the need to rebuild
the R.java file, which failure is much more rare when automatic build
is turned on.

BTW: I would definitely go ahead and load the code for all the
different version targets. If you do get to the point of doing
production code, you really do want to test it on all versions from at
least 1.6 through 2.1. You really should do 1.5 through 2.2, since 2.2
is likely to prove the latest version until 3.0 is released (no sooner
than October), and about 20%-30% of the phones out there are still
1.5.

On Jul 7, 5:49am, Matthew <ma77...@gmail.com> wrote:

--



Other Threads

1. Application is shutdown unexpectedly

Hello!

New to Android programming, I want to create the following layout:
1. Background e.g. cyan;
2. Two buttons, each of it be half of screen width wide,
   quarter of screen height high, with some example text;
3. The buttons should be centered, with a filler between them
   with the same height as the buttons.

Some of these requirements I'll have to do in my Activity's code, which 
currently only loads the view:


    @Override
    public void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);
    }

As this isn't too much, I must have done sth. wrong in my layout code:

<?xml version="1.0" encoding="UTF-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
    android:orientation="vertical"
    android:background="#18EDF5"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent"
    >
    <TableLayout>
        <TableRow android:id="@+id/main$p$top">
            <Button android:id="@+id/main$p$button1"
                android:background="@drawable/gradient_box"
                android:text="T E S T 1"
                android:textSize="32dip"
                android:layout_width="fill_parent"
                android:layout_height="fill_parent"
                android:layout_marginTop="10dp"
                android:layout_marginRight="40dp"
                android:layout_marginBottom="10dp"
                android:layout_marginLeft="40dp"
            />
        </TableRow>
        <View android:id="@+id/main$p$filler"
            android:layout_height="2dip"
            android:background="#FF909090"
        />
        <TableRow>
            <Button android:id="@+id/main$p$button2"
                android:background="@drawable/gradient_box"
                android:text="T E S T 2"
                android:textSize="32dip"
                android:layout_width="fill_parent"
                android:layout_height="fill_parent"
                android:layout_marginTop="10dp"
                android:layout_marginRight="40dp"
                android:layout_marginBottom="10dp"
                android:layout_marginLeft="40dp"
            />
        </TableRow>
    </TableLayout>
</LinearLayout>

It'd be great, if somebody could tell me, what I've forgotten here - 
guessing it's about some wrong/illegal/missing id, because the shutdown

might be caused by a NPE (however, just an assumption).

Kind regards

Peter

--

2. Galaxy 5 goes to.....

Galaxy 5 udah di suport resmi sama samsung ke froyo....{*filter*}tara baru ada
firmware buat us....ayo upgrade buat galaxy5er's

 http://www.***.com/ 

-- 
===============
"

3. Dungeon Hunter HD.. FREE!!

4. How i can migrate my app from 1.5 to 1.6 api fast and safe???

5. How to push the code changes to review.source.android.com

6. On disale logging status of Looper.getMainLooper().setMessageLogging(new Printer()) remains enable or becomes disable.

7. cara bikin aplikasi