:: wat is the limit for the size of the .apk file

by Imran » Wed, 19 Nov 2008 12:32:29 GMT

Sponsored Links
 guys help me.........


Other Threads

1. trying to show a progressdialog in a lengthy task


When i first launch my main intent, i check if the application was
updated and, if yes, i decompress some asset files. This task can take
up to 15 seconds (to decompress a 6MB zip file).

So, i was trying to show a ProgressDialog to the user. However,
nothing in hell makes the dialog appear.

The lengthy method is called from onCreate. I already tried to put it
in onStart, but same thing. I also tried to run it in the ui thread,
same thing: no dialog appears, even if "isShowing" returns true.

This is the code:

    while (...)
       // a 15-second task

What can i do to make the dialog really show up on screen?




2. 2 Dimensional Array not initializing correctly

I have a 2D array that I need to initialize. I have a class that holds
all my variables name "V", so in that class I have this:

static String[][] ModelInfo = new String[300][25];

That should make 300 array variables with 25 points in it, but it
doesn't as any time I try to reference anything other than
V.ModelInfo[0][0] I get arrayindexoutofboundsexception.

I have tried initializing this in a for loop, but even that won't
work. I've tried this:

V.ModelInfo = new String[300][];
                        for(int ForNum = 0; ForNum < 300; ForNum++){
                                V.ModelInfo[ForNum] = new String[25];
What the hell am I doing wrong? I found a work around at the moment
that does this:
                        for(int ForNum = 0; ForNum < 300; ForNum++){
                                V.ModelInfo[ForNum] = new StoredArray; 
//StoredArray is
initialized as String[25].

Is there some trick to getting 2D arrays to actually work like they
are supposed to?


3. Buat yang suka game

4. can an updated version of an app try to restore using a bundle containing older data?

5. Mau mirink di Jiung gak?

6. Cannot preview camcoder on android-2.1_r2 emulator

7. first call to setContentView taking more than 10 seconds