Emulator on Linux 10 times slower than on Windows

by Michael MacDonald » Tue, 08 Dec 2009 00:51:40 GMT


Sponsored Links
 've had bad Linux/hardware interactions with the emulator from audio. 
The emulator AFAIK uses the SDL audio libraries. Try starting the
emulator from the command line with the -noaudio flag and see if that
works better.

brian.schim...@googlemail.com wrote:

--



Other Threads

1. how to stop sound notification/let it only play once?

What Uri are you using for the notification sound? Sounds like the sound it
points to is a looping sound.


On Wed, Jun 24, 2009 at 6:39 PM, polzifer



> 

2. Key event delivery is sometimes slow

I have a separate thread to render game images at 40-50fps. But
sometimes the key response is slow. For example, though I pressed a
button to move the player, the player would stay still or keep moving
towards the original direction as if no keys were pressed. It will
normally last for about 5-10 seconds. The 'MENU' key is having the
same problem. The menu won't show up until after the 5-10 seconds. I
wrote out debug logs in onKeyDown() and onKeyUp(), and it showed me
they were not called during that peroid, regardless how many times I
pressed the key. And after that period, I would receive all key events
that were occurred during that period.

Is that a problem of OS thread scheduling? or just the event delivery
mechanism is slow on Android? Is there any way I can do to avoid this
from happening? It is really annoying.
--~--~---------~--~----~------------~-------~--~----~

3. New UI

4. App adds a button to another app

5. XMLVM

6. Eclipse plugin vs. conversion to Dalvik

7. How To Keep ListView Header From Scrolling With ListView Content