Cupcake wont start in emulator

by McLin » Mon, 30 Mar 2009 01:50:25 GMT


Sponsored Links
 Hi,

I have 2 Images build for cupcake, and the logo is new Blue Android
symbol, and it wont boot in emulator, with nor error, just the blue
android logo.

Any Idea?
--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by Jean-Baptiste Queru » Mon, 30 Mar 2009 01:52:04 GMT


 Does adb -e logcat show anything significant?

JBQ






-- 
Jean-Baptiste M. "JBQ" Queru
Android Engineer, Google.

Questions sent directly to me that have no reason for being private
will likely get ignored or forwarded to a public forum with no further
warning.

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Cupcake wont start in emulator

by McLin » Mon, 30 Mar 2009 02:12:46 GMT


 The last messege is:

D/quemud <28>: client_fd_received -> received channel id 2

then nothing




--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by McLin » Mon, 30 Mar 2009 02:15:02 GMT


 /DEBUG   (   20): debuggerd: Mar 29 2009 13:55:50

I/vold ( 19): Android Volume Daemon version 2.0

E/vold ( 19): Error opening switch name path '/sys/class/switch/
test2' (No such file or directory)

E/vold ( 19): Error bootstrapping switch '/sys/class/switch/
test2' (m)

E/vold ( 19): Error opening switch name path '/sys/class/switch/
test' (No such file or directory)

E/vold ( 19): Error bootstrapping switch '/sys/class/switch/
test' (m)

D/vold ( 19): Bootstrapping complete

E/flash_image( 26): can't find recovery partition

D/qemud ( 28): entering main loop

D/AndroidRuntime( 22):

D/AndroidRuntime( 22): >>>>>>>>>>>>>> AndroidRuntime START
<<<<<<<<<<<<<<

D/AndroidRuntime( 22): CheckJNI is ON

D/qemud ( 28): fdhandler_accept_event: accepting on fd 10

D/qemud ( 28): created client 0xe078 listening on fd 8

D/qemud ( 28): fdhandler_event: disconnect on fd 8

D/qemud ( 28): fdhandler_accept_event: accepting on fd 10

D/qemud ( 28): created client 0xf028 listening on fd 8

D/qemud ( 28): client_fd_receive: attempting registration for
service 'gsm'

D/qemud ( 28): client_fd_receive: -> received channel id 1

I/ ( 23): ServiceManager: 0xac38

D/AudioHardwareInterface( 23): Running in emulation - using generic
audio driver

W/AudioHardwareInterface( 23): Using stubbed audio hardware. No
sound will be produced.

D/A2dpAudioInterface( 23): A2dpAudioInterface::openOutputStream 1,
0, 0

D/A2DP ( 23): a2dp_init rate: 44100 channels: 2

D/A2DP ( 23): bluetooth_init

E/A2DP ( 23): bt_audio_service_open failed

D/A2DP ( 23): bluetooth_close

E/A2dpAudioInterface( 23): a2dp_init failed err: -111

D/A2dpAudioInterface( 23): A2dpAudioStreamOut::set 1, 0, 0

I/AudioFlinger( 23): AudioFlinger's thread ready to run for output 0

D/AudioFlinger( 23): setRouting 0 2 -1, tid 23, calling tid 23

D/AudioFlinger( 23): setRouting 1 2 -1, tid 23, calling tid 23

D/AudioFlinger( 23): setRouting 2 1 -1, tid 23, calling tid 23

E/AudioFlinger( 23): mA2dpDisableCount is already zero

I/AudioFlinger( 23): AudioFlinger's thread ready to run for output 1

I/CameraService( 23): CameraService started: pid=23

D/AndroidRuntime( 22): --- registering native functions ---

I/Zygote ( 22): Preloading classes...

D/dalvikvm( 22): GC freed 763 objects / 42128 bytes in 6ms

D/dalvikvm( 22): GC freed 278 objects / 17200 bytes in 7ms

D/dalvikvm( 22): GC freed 204 objects / 12424 bytes in 5ms

D/dalvikvm( 22): GC freed 441 objects / 28216 bytes in 5ms

D/dalvikvm( 22): GC freed 3570 objects / 170856 bytes in 15ms

D/dalvikvm( 22): GC freed 11557 objects / 411296 bytes in 29ms

D/dalvikvm( 22): GC freed 10661 objects / 447048 bytes in 30ms

D/dalvikvm( 22): GC freed 10558 objects / 440984 bytes in 34ms

D/dalvikvm( 22): GC freed 14636 objects / 516520 bytes in 39ms

D/dalvikvm( 22): GC freed 11453 objects / 487736 bytes in 38ms

D/dalvikvm( 22): GC freed 5527 objects / 233168 bytes in 31ms

D/dalvikvm( 22): GC freed 348 objects / 37096 bytes in 28ms

D/dalvikvm( 22): GC freed 778 objects / 48416 bytes in 38ms

D/dalvikvm( 22): GC freed 321 objects / 36976 bytes in 39ms

D/dalvikvm( 22): GC freed 476 objects / 29416 bytes in



Cupcake wont start in emulator

by Jean-Baptiste Queru » Mon, 30 Mar 2009 03:22:51 GMT


 t's not exactly clear to me what'd going on, but it seems to me that
you're trying to run a dream image on the emulator (different
"hardware", different drivers), and that might be the cause of your
problems.

JBQ

On Sun, Mar 29, 2009 at 11:14 AM, McLin <mcli...@googlemail.com> wrote:



--
Jean-Baptiste M. "JBQ" Queru
Android Engineer, Google.

Questions sent directly to me that have no reason for being private
will likely get ignored or forwarded to a public forum with no further
warning.

--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by McLin » Mon, 30 Mar 2009 03:45:47 GMT


 ts build like instruction and just copy the HTC Dream Image to
Emulator, previous versions works, ok if I flash these Images to my
Dev Phone it works?

On Mar 29, 9:22pm, Jean-Baptiste Queru <j...@android.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by Jean-Baptiste Queru » Mon, 30 Mar 2009 04:36:30 GMT


 es, I think that the problem is that you're trying to run a Dream
build on the emulator, which might not actually work. You'll probably
have better luck doing a generic build instead.

JBQ

On Sun, Mar 29, 2009 at 12:45 PM, McLin <mcli...@googlemail.com> wrote:



--
Jean-Baptiste M. "JBQ" Queru
Android Engineer, Google.

Questions sent directly to me that have no reason for being private
will likely get ignored or forwarded to a public forum with no further
warning.

--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by David Turner » Mon, 30 Mar 2009 05:53:17 GMT


 It seems that you're trying to run a cupcake system image with a SDK 1.1
emulator binary.
This will not work, you need to run the cupcake emulator as well, which is
built for you in out/host/<system>/bin/emulator

If this is not the case; please give exact information that details the way
you configure and build your system image, as well as invoke the emulator.







--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by McLin » Thu, 02 Apr 2009 03:44:39 GMT


 Thx for answer...

I've found this storie  http://strazzere.com/blog/?cat=59 on goolge 
search for tips to build a stable cupcake.

Did anybody know more files I can use from my ADP to make mor hardware
useable?
--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by webber » Fri, 10 Apr 2009 01:56:36 GMT


 i meet the same problem here
i was building the system image with "TARGET_PRODUCT=htc_dream" first
but my phone was stopped on the Blue Android symbol(same as McLin)
after flash the new system.img, boot.img, userdata.img, recovery.img
the adb logcat showed the same msg as McLin's

another horrible thing is
after that, i tried to build the system image with
"TARGET_PRODUCT=generic", it goes with the same log message and the
same screen now(where is my lovely green android>"<).

any idea about this log message?


--~--~---------~--~----~------------~-------~--~----~



Cupcake wont start in emulator

by webber » Fri, 10 Apr 2009 10:50:40 GMT


 i solved this problem today by pluging my ADP1 when i boot it i think it may be caused by the leak of voltage
the new cupcake source required more powerful voltage to boot
--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. 1.5 Example GLSurfaceViewActivity.java fails after stop/resume

I am having trouble with the example for use of GLSurfaceView (see
http://developer.android.com/guide/samples/ApiDemos/src/com/example/android/apis/graphics/GLSurfaceViewActivity.html
).

I created a normal Android project in the Eclipse IDE, added the
GLSurfaceViewActivity class and related from the sample directory, set
the activity to GLSurfaceViewActivity, and ran it on the emulator.

It worked. Then I hit the home button, launched another app, hit home
again, and launched my test app again. This time, I got a blank screen
(with now exceptions thrown in logcat);.

Any ideas?

I was motivated to try this example because if have been having the
same trouble with my own app - discussed
iat

2. noob Question button functions

Hey im a new developer ans im having trouble with button functions i
have a menu created but how do i give them functions so when there
pressed they can actually do something?

--~--~---------~--~----~------------~-------~--~----~

3. How Can I Block Unwanted Calls.

4. Populate spinner

5. Android Labrador Problem

6. how to receive general IO events ?

7. Publishing Upgrades on Android Market ... Still Relevant?