Help!!! Unknown Error - java.lang.NullPointerException :: Android Packaging Problem

by Chris » Thu, 21 Oct 2010 06:34:25 GMT


Sponsored Links
 I'm getting this crazy error on multiple projects, even when I revert
back to prior versions that compiled just fine.

Unknown Error - java.lang.NullPointerException Android Packaging
Problem
Path is blank
Location is Unknown.

I've tried:

1 - Project -> Clean -> All
2 - Deleting .metadata folder
3 - reimporting projects into the eclipse
4 - reverting my projects back to prior working versions using git

Please please please help... I just can't get anything to compile now,
and I've searched for solutions here and on eclipse forums.

--



Help!!! Unknown Error - java.lang.NullPointerException :: Android Packaging Problem

by Bret Foreman » Thu, 21 Oct 2010 06:52:30 GMT


 This sounds more like a problem with your dev system than with your
code. Try re-installing Eclipse and the SDK. Export all your Eclipse
preferences first, of course (File->Export->General->Preferences).

--


Sponsored Links


Help!!! Unknown Error - java.lang.NullPointerException :: Android Packaging Problem

by Chris » Fri, 22 Oct 2010 00:05:32 GMT


 Finally figured it out.

==Short version

My .project file was corrupted and I needed to manually update linked
library locations.  Since the .project file was pointing to the wrong
place, a null pointer exception was thrown.

==Long Version

For some reason, the GUI and project settings were disconnected form
one another.  When I went into project settings, my libraries looked
to be correctly linked and properly found in the build path.

However, when going into the .project file using a text editor, there
were straggler linked libraries.  (ie multiple versions of the same
library, pointing to two different locations)

Most likely user error on my part, but something to keep in mind if
you get the "unknown packaging error".

Thanks for the suggestion Bret... I did reinstall everything, but the
problem persisted, as per the fix above.

--



Other Threads

1. Running a thttpd server on android

Hi ,

There is a requirement to run a thttpd server on android, so as to run
a web-service on the android device .
 I need suggestions how to start of with . Any help is appreciated.

Regards
Sambit.

-- 

2. DNS problems in our app

I had gotten reports from a few users that they couldn't login to our
app (which makes HTTP calls to our site) or visit our website in their
browser, so I added some code to our latest build to check what IP our
host name is resolving to.  I've gotten reports from several different
users now that they get 127.0.0.1 for our hostname
(www.audiogalaxy.com) when the app starts, which obviously isn't going
to work.

At least one confirmed that he doesn't have any kind of proxy software
installed.  Another got the problem on 2.2, but after going back to
2.1 the problem went away.

Has anyone seen this sort of thing?  Any suggestions for figuring out
what is going on?

Thanks,
Tom

-- 

3. detect that you are on the emulator and not on real device

4. RTSP Video packet loss ratio, jitter and delay

5. Array adapter - ListView [databasing?]

6. Tables

7. My first post -- ArrayAdapter question