Not loading Phone.apk on emulator

by vishnu » Tue, 08 Sep 2009 11:09:59 GMT


Sponsored Links
 i All,

I am porting s3c6410 on emulator (only platform side not kernel). I
removed the hardware dependencies (from hardware folder). when i am
running emulator it's not able to load Phone.apk showing following :

Could not find end-of-central-directory in Zip
D/asset ( 634): failed to open Zip archive '/system/app/Phone.apk'
W/PackageParser( 634): Unable to read AndroidManifest.xml of /system/
app/Phone.apk
W/PackageParser( 634): java.io.FileNotFoundException:
AndroidManifest.xml
W/PackageParser( 634): at
android.content.res.AssetManager.openXmlAssetNative(Native Method)
W/PackageParser( 634): at
android.content.res.AssetManager.openXmlBlockAsset(AssetManager.java:
471)
W/PackageParser( 634): at
android.content.res.AssetManager.openXmlResourceParser
(AssetManager.java:439)
W/PackageParser( 634): at
android.content.pm.PackageParser.parsePackage(PackageParser.java:265)
W/PackageParser( 634): at
com.android.server.PackageManagerService.scanPackageLI
(PackageManagerService.java:1759)
W/PackageParser( 634): at
com.android.server.PackageManagerService.scanDirLI
(PackageManagerService.java:1709)
W/PackageParser( 634): at
com.android.server.PackageManagerService.<init>
(PackageManagerService.java:464)
W/PackageParser( 634): at
com.android.server.PackageManagerService.main
(PackageManagerService.java:261)
W/PackageParser( 634): at com.android.server.ServerThread.run
(SystemServer.java:119)

and later it crash:

: Unable to start service Intent
{ action=android.accounts.IAccountsService comp=
{com.google.android.googleapps/
com.google.android.googleapps.GoogleLoginService} }: not found
W/AccountMonitor( 634): Couldn't connect to Intent
{ action=android.accounts.IAccountsService comp=
{com.google.android.googleapps/
com.google.android.googleapps.GoogleLoginService} } (Missing service?)
I/SystemServer( 634): Starting System Content Providers.
I/ActivityThread( 634): Publishing provider sync:
android.content.SyncProvider
I/SystemServer( 634): Starting Battery Service.
I/SystemServer( 634): Starting Hardware Service.
D/qemud ( 547): fdhandler_accept_event: accepting on fd 10
D/qemud ( 547): created client 0xe078 listening on fd 8
D/qemud ( 547): client_fd_receive: attempting registration for
service 'hw-control'
D/qemud ( 547): client_fd_receive: -> received channel id 2
D/qemud ( 547): client_registration: registration succeeded for
client 2
W/HAL ( 634): load: module=/system/lib/hw/lights.goldfish.so
error=Cannot find library
W/HAL ( 634): load: module=/system/lib/hw/lights.s3c6410.so
error=Cannot find library
W/HAL ( 634): load: module=/system/lib/hw/lights.default.so
error=Cannot find library
E/ActivityThread( 634): Failed to find provider info for settings
W/dalvikvm( 634): threadid=31: thread exiting with uncaught exception
(group=0x4000fe70)
E/AndroidRuntime( 634): Uncaught handler: thread PowerManagerService
exiting due to uncaught exception
E/AndroidRuntime( 634): *** EXCEPTION IN SYSTEM PROCESS. System will
crash.
E/AndroidRuntime( 634): java.lang.NullPointerException
E/AndroidRuntime( 634): at android.content.ContentQueryMap.<init>
(ContentQueryMap.java:65)
E/AndroidRuntime( 634): at
com.android.server.PowerManagerService.initInThread
(PowerManagerService.java:418)
E/AndroidRuntime( 634): at com.



Other Threads

1. ContentProvider.query() is not being called.

I have been playing around with the SearchableDictionary sample
application trying to understand it.

I set a breakpoint in DictionaryProvider.query() and verified that
it's going in there when I turn on search for this application
(settings > search > searchable items > Searchable Dictionary).

Then I tried modifying the AndroidManifest.xml file, changing the
launch activity to .WordActivity --
        <!-- The default activity of the app.  Can also display search
results. -->
        <activity android:name=".SearchableDictionary"
                android:theme="@android:style/Theme.NoTitleBar">

        </activity>

        <!-- Displays the definition of a word. -->
        <activity android:name=".WordActivity"
                android:label="@string/app_name"
                android:theme="@android:style/Theme.NoTitleBar">

            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category
android:name="android.intent.category.LAUNCHER" />
            </intent-filter>

            <!-- Receives the search request. -->
            <intent-filter>
                <action android:name="android.intent.action.SEARCH" />
                <category
android:name="android.intent.category.DEFAULT" />
            </intent-filter>

            <!-- Points to searchable meta data. -->
            <meta-data android:name="android.app.searchable"
                    android:resource="@xml/searchable"/>

                </activity>

I also had to change WordActivity so it would startup (albeit not be
useful) --

//        Intent intent = getIntent();
//
//        String word = intent.getStringExtra("word");
//        String definition = intent.getStringExtra("definition");
        String word = "word";
        String definition = "definition";

My expectation was that when I ran it and typed something in the QSB
(search box on the main android page), it would still trigger the
breakpoint.  It's like it doesn't even recognize that the app should
be part of the search anymore.  I try moving the manifest changes back
and it goes back to working.

The thing that led me down this path was that I am trying to write my
own ContentProvider, and I can't get the QSB to call my query method.
So what gives with this sample code here?  What is preventing (or
enabling) query() to be called from the QSB?

tia.
--~--~---------~--~----~------------~-------~--~----~

2. SurfaceView -Memory Creation

Hi ,

I understand that SurfaceView initializes the Renderer and the
OnsurfaceCreate(gl10,context) ....How does the OnsurfaceCreate GL1.0 Context
and where is the EGL initialisation to Create a Window and Pixmap Surface is
Happening ?? Does it call GLCanvas for Surface Creation or it Directly
access the Memory from the GPU ??
If It is allocating Memory Directly from the GPU what is GlCanvas Used For
??

Thanks in advance
-- 
surya

--~--~---------~--~----~------------~-------~--~----~

3. Check for internet connection

4. Checking of already set alarm

5. Fix for Camera with Preview Callback crash

6. Streaming encoded video via RTP