Scrolling TextView that automatically scrolls to bottom

by Roman Romano » Mon, 26 Jan 2009 07:17:20 GMT


Sponsored Links
 Hi All,

I have a textview that is wrapped in a scrollview and works nicely.
The only problem is that when text is appended to the textview so as
to induce scrollability, it doesn't automatically scroll to the bottom
of the textview, ihave to manually scroll down.
Is there any way to achieve this 'keep-last-appended-text-in-view'?

many thanks all

Roman

--~--~---------~--~----~------------~-------~--~----~



Scrolling TextView that automatically scrolls to bottom

by Roman Romano » Mon, 26 Jan 2009 22:01:58 GMT


 Fixed it i think.
in the method that appends the text, i needed to set fullScroll
(FOCUS_DOWN) on the ScrollView.
Hope that makes sense to anyone experiencing similar issues
Roman


On Jan 25, 11:17pm, Roman Romano <very.cross...@googlemail.com>


--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Scrolling TextView that automatically scrolls to bottom

by mrspiteri » Thu, 29 Jan 2009 01:10:13 GMT


 thanks I was looking for the same thing. it works though it doesn't
seem to scroll to the very bottom...leaves about 1 line so the bottom
(newest line) is slightly faded.





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Incorrect RowId with SQLite using FTS3 on Android 2.2

I am experiencing an incorrect rowid value with sqlite and fts3.

Basically, the first two rows are inserted and the rowId is 1 and 2
respectively. The third insert however returns 4 instead of 3.

I dropped the following log message in my contentprovider when
inserting a row:

    SQLiteDatabase database =
    databaseHelper.getWritableDatabase();
    long rowId = database.insert(NOTES_TABLE, Note.NOTE, values);
    Log.d("NoteProvider", "RowId inserted was " + rowId);

The output of that log message is:

    02-21 21:10:12.773: DEBUG/NoteProvider(2486): RowId inserted was 1
    02-21 21:10:20.623: DEBUG/NoteProvider(2486): RowId inserted was 2
    02-21 21:10:25.883: DEBUG/NoteProvider(2486): RowId inserted was 4

So what happened to 3?

Also, I exported the sqlite database so I could look at in a SqLite
browser and the content table shows 1, 2 and 3.

So 3 was created but 4 was returned.

I ran my testing up to 10, and the rowId was sequential afterwards,
but still off by 1.

The database create script is:

    database.execSQL("CREATE VIRTUAL TABLE " + NOTES_TABLE + "
    USING fts3 ("
               + Note.TITLE + ", "
               + Note.NOTE + ", "
               + Note.CREATED_DATE + ", "
               + Note.MODIFIED_DATE + ");");

I am assuming I have done something horribly wrong, but cannot figure
out what it is.
Can anyone help me out?

** This is a repost of my question on stackoverflow.
http://stackoverflow.com/questions/5078788/incorrect-rowid-with-sqlite-using-fts3-on-android-2-2

-- 

2. Freeze problem on a lot of devices. Help Please!!!

Could it be lock starvation? I'm not sure if adb has something like
jstack, to get a list of the locked and "waiting on" IDs?

-- 

3. SDK Manager fails to update itself

4. Network stack

5. Getting Exception while creating..?

6. Is LVL implementation worth the trouble?

7. specify dollars for america, euros for europe.