N1 update announced

by JP » Wed, 03 Feb 2010 04:28:13 GMT


Sponsored Links
 Speaking of Engadget...

 http://www.engadget.com/2010/02/02/nexus-one-gets-a-software-update-enables-multitouch/ 

I'll give it a shot some time this PM. If pinch-and-zoom aka
multitouch works as advertised, kudos.

--



N1 update announced

by Kent Loobey » Wed, 03 Feb 2010 05:28:11 GMT


 


Here is a link to a video on multitouch.

 http://www.viddler.com/explore/engadget/videos/1065/15.638 

--


Sponsored Links


N1 update announced

by JP » Wed, 03 Feb 2010 12:34:31 GMT


 I skipped the video and jumped right to the update.

Nice. Finally.

In Maps it's not quite perfect; after releasing, the map animates to a
discrete zoom level.

Along with this update, we'll probably also need an update to the SDK.
Overlays (of my app anyway) do not receive draw events   during
multitouch pinching. Only after release, when the map animates to a
discrete zoom level, do the draw events come through.








--



N1 update announced

by Kent Loobey » Wed, 03 Feb 2010 12:52:03 GMT


 


Where did you find the update?
 




--



N1 update announced

by JP » Wed, 03 Feb 2010 14:05:16 GMT


 I followed the following instructions:
 http://www.androidcentral.com/how-manually-update-your-nexus-one 
includes link to download mirror
(They assume you know how to use adb)

Disclaimer: I do this with relative impunity; I use the N1 mostly as
dev phone only.










--



N1 update announced

by JP » Thu, 04 Feb 2010 02:30:48 GMT


 


A more serious issue discovered. For lack of a better description, app
sporadically disconnects from the underlying MapView, which turns
completely blank (not even the grid is being displayed). Manually
zooming brings it back but it totally throws off program-driven
zooming and animate-to's.

--



N1 update announced

by Tim » Fri, 05 Feb 2010 01:22:07 GMT


 


This make sense (although maybe it should be an option). The map is
only rendered on Google's servers at discrete zoom levels. It will
look best if the tiles are drawn 1:1, otherwise you'll get blurring or
aliasing.

--



Other Threads

1. UBIFS issues

Hi. I'm trying to boot Android (w/ Linux-2.6.31) on a UBIFS partition.

I created previously one UBI volume:

  $ flash_eraseall /dev/mtd3
  $ ubidetach /dev/ubi_ctrl -m 3
  $ ubiformat /dev/mtd3 -y
  $ ubiattach /dev/ubi_ctrl -m 3
  $ ubimkvol /dev/ubi0 -N system -m

  $ mount -t ubifs ubi0:system /mnt/ubi

     # copied the rootfs

  $ umount /mnt/ubi

Next I defined my kernel cmdline on u-boot:

$ setenv bootargs 'console=ttymxc0,115200 androidboot.console=ttymxc0
rootfstype=ubifs ubi.mtd=3 init=/bin/sh di1_primary'

but I can't mount...

UBIFS error (pid 1): ubifs_get_sb: cannot open "/dev/root", error -22
List of all partitions:
1f00            3072 mtdblock0 (driver?)
1f01            5120 mtdblock1 (driver?)
1f02            1024 mtdblock2 (driver?)
1f03          102400 mtdblock3 (driver?)
1f04           10240 mtdblock4 (driver?)
1f05           10240 mtdblock5 (driver?)
1f06          392192 mtdblock6 (driver?)
No filesystem could mount root, tried:  ubifs

-22 means that I using in someway an 'Invalid argument'. A tried some
variations on cmdline (i.e: root=/dev/mtdblock3).

I .config is defined with:

# UBI - Unsorted block images
CONFIG_MTD_UBI=y
CONFIG_MTD_UBI_WL_THRESHOLD=4096
CONFIG_MTD_UBI_BEB_RESERVE=1
CONFIG_MTD_UBI_DEBUG=y
CONFIG_MTD_UBI_DEBUG_MSG=y
CONFIG_UBIFS_FS=y
CONFIG_UBIFS_FS_LZO=y
CONFIG_UBIFS_FS_ZLIB=y
(...)

I considered two things. 1) I'm using a wrong rootfs... 2) I'm passing
an invalid cmdline param.

Any points?

BR

--tm

-- 
unsubscribe: android-porting+unsubscr...@googlegroups.com
website: 

2. Bluetooth name and address in 1.5

I was wondering if its possible to get the bluetooth name and / or
address in 1.5? The BluetoothAdapter class isnt availabel in that
release. Is there another way to get this info on 1.5?
Thanks

-- 

3. Tanya : desire tmob froyo

4. drawBitmap differences between 2.1 and 2.2

5. Getting error while trying to compile CameraHardware.cpp

6. LG OPTIMUS

7. Spica Terendam Ai