Android Dev Phone on AT&T?

by Clint Fisher » Sat, 13 Dec 2008 03:22:50 GMT


Sponsored Links
 The fix that worked for me:

In addition to the APN below, which didn't seem to work,  I created a new
APN by ONLY setting the following values:

name: att
apn: wap.cingular
password: CINGULAR1

I was actually quite surprised that this worked, but it did, and it allowed
me to get past the initial phone setup.

BTW, check their terms of service before calling & "negotiating" your data
rate.  Their terms are very restrictive,
especially regarding unsupported phones.  If you've already got the
flat-rate PDA Plan, you're probably safe, but
who knows.  I'm thinking of ditching AT&T (again) and just going with
T-Mobile.





--~--~---------~--~----~------------~-------~--~----~



Android Dev Phone on AT&T?

by Clint Fisher » Sat, 13 Dec 2008 03:23:20 GMT


 I just got my Android Dev Phone today and threw my AT&T (formerly
Cingular) SIM card in there (with unlimited data plan), and cannot get
it to work.

My APN settings:

name: AT&T
apn: wap.cingular
proxy blank
port blank
username:w...@cingulargprs.com
password:CINGULAR1
server blank
mmsc:  http://mmsc.cingular.com 
mms proxy: wireless.cingular.com
mms port: 80
mcc:310
mnc:410
apn type blank

Any ideas?  Has anyone successfully gotten this to work with their
AT&T Wireless SIM card?

Unfortunately, without the initial activation it seems, the phone is
just a spendy brick.  It won't let me get past the google sign-up.
Any help would be greatly appreciated.

Thanks!
-Clint

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Android Dev Phone on AT&T?

by Mark K » Sat, 13 Dec 2008 08:46:36 GMT


 Just set the name and apn as you have, leave all the other fields
blank. This worked for me, moved my SIM card from a BB to my unlocked
G1 phone, now it works fine on AT&T.

                                           Mark



--~--~---------~--~----~------------~-------~--~----~



Android Dev Phone on AT&T?

by hello tommie » Mon, 22 Dec 2008 10:12:37 GMT


 yes, thank you this worked for me also.
just hit the menu button on start up.





--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Help in simple read/write applications.

I am writing two applications A and B. A writes a string into a file
and B has to read from the same file. Both are signed by the same key
and have shared UIDs. App A runs fine, by writing a specified string
into the file(stored in internal memory). But while running app B on
the emulator, I get an error box which says that the application
stopped unexpectedly. Can anyone help me in this direction? Thanks!!

-- 

2. In-app purchase signature verification with PHP openssl

In an attempt to follow some of the security guidelines for in-app
purchase here:
http://developer.android.com/guide/market/billing/billing_best_practices.html

I am trying to do signature validation on a server instead of in the
app iteself. I would ideally like to use the php openssl libraries and
it looks like code such as the following should work:

<?php
// $data and $signature are assumed to contain the data and the
signature

// fetch public key from certificate and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pubkeyid = openssl_get_publickey($cert);

// state whether signature is okay or not
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1) {
    echo "good";
} elseif ($ok == 0) {
    echo "bad";
} else {
    echo "ugly, error checking signature";
}
// free the key from memory
openssl_free_key($pubkeyid);
?>

I replace signature with the base64 decoded signature string in the
app purchase bundle and the use the data from the same bundle. The
public key needs to be in PEM format and I added the BEGIN and END
tokens and some line breaks.

My problem is that I can not get this PHP code to successfully verify
the data/signature and I do not know what needs to change to get it to
work correctly.

If I use openssl, create a private and public key, create a signature
for the same data using sha1 and run it through the above php code, it
works fine and validate successfully.

Here is how I use OpenSSL:

  openssl genrsa -out private.pem
  openssl rsa -in private.pem -pubout -out public.pem
then i use the private.pem and some php code to generate a signature:
...
openssl_sign($data, $signature, $pkeyid);
...

Does anyone have any working sample php code with server side
validation of in-app signatures?

I could just run the equivalent java code that is in the sample
application, and that seems to work ok, but I would like to use php
directly if possible.

Thanks,
Nate



-- 

3. [WTB] Accessory Motorola Xoom

4. # downloads seems to get stuck in marketplace admin console?

5. What is the minimum hardware requirements to run the Android emulator

6. BootCamp Android di Jogja

7. What are the best 2D, 3D game engine for Android?