3G connection sometimes missing from emulator

by Marton Kodok » Sun, 01 Nov 2009 23:21:15 GMT


Sponsored Links
 Hello,

I am using the Emulator via Eclipse on a Windows 7 OS.
Sometimes when the emulator is launched the Internet connection is missing,
also the 3G icon is missing.
I have to restart the whole emulator to get it show up. Sometimes it shows
up after several restarts.
Is this a know bug?

-- 
Mrton

--



3G connection sometimes missing from emulator

by pentium10 » Sat, 14 Nov 2009 02:14:48 GMT


 nyone on this one?

this is the output for LogCat W level when the emulator starts without
3G icon.

11-13 20:04:37.287: ERROR/vold(538): Error opening switch name path '/
sys/class/switch/test2' (No such file or directory)
11-13 20:04:37.296: ERROR/vold(538): Error bootstrapping switch '/sys/
class/switch/test2' (No such file or directory)
11-13 20:04:37.338: ERROR/vold(538): Error opening switch name path '/
sys/class/switch/test' (No such file or directory)
11-13 20:04:37.338: ERROR/vold(538): Error bootstrapping switch '/sys/
class/switch/test' (No such file or directory)
11-13 20:05:08.047: ERROR/MemoryHeapBase(568): error opening /dev/
pmem: No such file or directory
11-13 20:05:08.057: ERROR/SurfaceFlinger(568): Couldn't open /sys/
power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake
11-13 20:05:08.180: ERROR/libEGL(568): couldn't load <libhgl.so>
library (Cannot load library: load_library[984]: Library 'libhgl.so'
not found)
11-13 20:05:08.207: WARN/HAL(568): load: module=/system/lib/hw/
copybit.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.goldfish.so' not found
11-13 20:05:08.218: WARN/HAL(568): load: module=/system/lib/hw/
copybit.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.default.so' not found
11-13 20:05:08.218: WARN/SurfaceFlinger(568): ro.sf.lcd_density not
defined, using 160 dpi by default.
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
copybit.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.goldfish.so' not found
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
copybit.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.default.so' not found
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
overlay.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/overlay.goldfish.so' not found
11-13 20:05:08.247: WARN/HAL(568): load: module=/system/lib/hw/
overlay.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/overlay.default.so' not found
11-13 20:05:09.097: WARN/UsageStats(568): Usage stats version changed;
dropping
11-13 20:05:09.337: ERROR/libEGL(585): couldn't load <libhgl.so>
library (Cannot load library: load_library[984]: Library 'libhgl.so'
not found)
11-13 20:05:11.347: WARN/PackageManager(568): Running ENG build: no
pre-dexopt!
11-13 20:05:14.489: WARN/PackageParser(568): Intent filter for
activity ActivityIntentInfo{43801668 com.android.camera.ReviewImage}
defines no actions
11-13 20:05:18.677: WARN/PackageManager(568): Unknown permission
android.permission.ADD_SYSTEM_SERVICE in package com.android.phone
11-13 20:05:18.687: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH in package
com.android.providers.contacts
11-13 20:05:18.687: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH.cp in package
com.android.providers.contacts
11-13 20:05:18.697: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH in package
com.android.development
11-13 20:05:18.697: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH.ALL_SERVICES in
package com.android.development
11-13 20:05:18.697: WARN/PackageManage


Sponsored Links


Other Threads

1. Application Licensing

I'm using android licensing in a paid app that I've published a few
months ago.

Until yesterday ( 16 May 2011 ) everything was working fine. Since
yesterday about 4pm GMT + 1 I started to receive complaints from
several customers saying that the application, that was working for 2
months, was not working due to license validation failures.

Before May 16, a couple of customers complained about licensing check
failing and it was solved by enabling the network access and
restarting the application ( the license was validated and the
application continued to work ).

Since yesterday, all the costumers that complained about this issue
could not solve this problem by enabling network access and others are
saying that sometimes they start the application ( validation
succeeds ) and after a few minutes of usage and restarting the
application it starts the validation process again and fails.

Yesterday, I bought the same application so far I've check that for a
new purchase the validity timestamp was set for 24h.
Today after 6pm I have launched this application and the validation
process started ( as expected ), the validity timestamp was set to
tomorrow around 2pm. During this tests I took precautions about
removing the gmail account from the test accounts ( licensing and in-
app billing test accounts ). It seems that the license validity
timestamp, in the past few days, is lower than 24h and as reported by
some customers sometimes is less than a couple of minutes.

I'm using ServerManagedPolicy without any changes to the default
configuration.

I'm not understanding this behaviour , because the application did not
change since the last time that I published, and now after a few
months I'm receiving reports about this issue and I can't reproduce
this problem.

Is someone having the same problem?
Can you help me?

Thanks.



-- 

2. Replace Stock Voicemail?

I noticed Google Voice is able to replace the stock voicemail app or
at least the voicemail number. How can I do this with my app? Thanks!

Shaun

-- 

3. WifiManager running in emulator

4. Multiple layers

5. Regarding accessing a Content Provider from standalone base class

6. Tabs

7. Reference an integer resource for Android manifest versionCode