3G connection sometimes missing from emulator

by Marton Kodok » Sun, 01 Nov 2009 23:21:15 GMT


Sponsored Links
 Hello,

I am using the Emulator via Eclipse on a Windows 7 OS.
Sometimes when the emulator is launched the Internet connection is missing,
also the 3G icon is missing.
I have to restart the whole emulator to get it show up. Sometimes it shows
up after several restarts.
Is this a know bug?

-- 
Mrton

--



3G connection sometimes missing from emulator

by pentium10 » Sat, 14 Nov 2009 02:14:48 GMT


 nyone on this one?

this is the output for LogCat W level when the emulator starts without
3G icon.

11-13 20:04:37.287: ERROR/vold(538): Error opening switch name path '/
sys/class/switch/test2' (No such file or directory)
11-13 20:04:37.296: ERROR/vold(538): Error bootstrapping switch '/sys/
class/switch/test2' (No such file or directory)
11-13 20:04:37.338: ERROR/vold(538): Error opening switch name path '/
sys/class/switch/test' (No such file or directory)
11-13 20:04:37.338: ERROR/vold(538): Error bootstrapping switch '/sys/
class/switch/test' (No such file or directory)
11-13 20:05:08.047: ERROR/MemoryHeapBase(568): error opening /dev/
pmem: No such file or directory
11-13 20:05:08.057: ERROR/SurfaceFlinger(568): Couldn't open /sys/
power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake
11-13 20:05:08.180: ERROR/libEGL(568): couldn't load <libhgl.so>
library (Cannot load library: load_library[984]: Library 'libhgl.so'
not found)
11-13 20:05:08.207: WARN/HAL(568): load: module=/system/lib/hw/
copybit.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.goldfish.so' not found
11-13 20:05:08.218: WARN/HAL(568): load: module=/system/lib/hw/
copybit.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.default.so' not found
11-13 20:05:08.218: WARN/SurfaceFlinger(568): ro.sf.lcd_density not
defined, using 160 dpi by default.
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
copybit.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.goldfish.so' not found
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
copybit.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/copybit.default.so' not found
11-13 20:05:08.237: WARN/HAL(568): load: module=/system/lib/hw/
overlay.goldfish.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/overlay.goldfish.so' not found
11-13 20:05:08.247: WARN/HAL(568): load: module=/system/lib/hw/
overlay.default.so error=Cannot load library: load_library[984]:
Library '/system/lib/hw/overlay.default.so' not found
11-13 20:05:09.097: WARN/UsageStats(568): Usage stats version changed;
dropping
11-13 20:05:09.337: ERROR/libEGL(585): couldn't load <libhgl.so>
library (Cannot load library: load_library[984]: Library 'libhgl.so'
not found)
11-13 20:05:11.347: WARN/PackageManager(568): Running ENG build: no
pre-dexopt!
11-13 20:05:14.489: WARN/PackageParser(568): Intent filter for
activity ActivityIntentInfo{43801668 com.android.camera.ReviewImage}
defines no actions
11-13 20:05:18.677: WARN/PackageManager(568): Unknown permission
android.permission.ADD_SYSTEM_SERVICE in package com.android.phone
11-13 20:05:18.687: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH in package
com.android.providers.contacts
11-13 20:05:18.687: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH.cp in package
com.android.providers.contacts
11-13 20:05:18.697: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH in package
com.android.development
11-13 20:05:18.697: WARN/PackageManager(568): Unknown permission
com.google.android.googleapps.permission.GOOGLE_AUTH.ALL_SERVICES in
package com.android.development
11-13 20:05:18.697: WARN/PackageManage


Sponsored Links


Other Threads

1. HOW TO GET THE TRASACTION NOTIFICATION WHILE NETWORK GOES.

hi,

while the transaction is in process and my application crashes.So how
will get the information about that transaction.As I am just waiting
for the confirm notification.How can I test this scenario with the
Static Values.?

Can any one please help..

thanks
bins

-- 

2. List Selector Problem

Hi,

I am facing problem with list selector.

The code is as follows:

*1) Applied list selector in the listview layout*

<ListView
        android:id="@+id/android:list"
        android:layout_width="fill_parent"
        android:layout_height="fill_parent"
        android:layout_weight="1"
        android:listSelector="@drawable/selector_list"
        />

*2) list_selector.xml*

<?xml version="1.0" encoding="utf-8"?>
<selector xmlns:android="http://schemas.android.com/apk/res/android">
    <item android:state_focused="true" state_selected="false"
android:drawable="@drawable/black"/>
    <item android:state_focused="false" state_selected="true"
android:drawable="@drawable/black"/>
    <item android:state_focused="false" state_selected="true"
android:drawable="@drawable/grey"/>
</selector>


Still it is not taking any effect on the list item getting displayed.  The
default color is coming on selection instead of customised one.
I will be grateful if any help is provided on this

Thanks!!

-- 

3. [Map] Conflict in to MapController between Zoom Level and AnimateTo ?

4. How to mount /data partition into innersd of my Android device

5. Native email Client di Android Froyo.. support push email kah?

6. how to prevent the app be killed by 鈥渦nmount media鈥?change to usb storage mode)

7. Video Sony Ericsson Arc