peristiwa 65 tidak boleh dilupakan..

by Teguh Ostenrik » Sun, 07 Sep 2008 10:28:38 GMT


Sponsored Links
 i akupunktur saja Bung



On 9/5/08 4:12 PM, "putu oka sukanta" <[EMAIL PROTECTED]> wrote:

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Flash CKDroid 1.5 - gagal

lagi coba flash CKDroid 1.5 sebelum ditingkatkan ke CKDroid 1.5.2.1
dan mandeg di verifying update package, E: corrupt file:
system/app/livewallpapers.apk. langsung deh install aborted.

Pakai recovery rom amon_ra v1.5.2.

mohob pencerahan...

salam,
Hermanto

-- 
"Indonesian Android Community [id-android]" 

2. Animations with transparent background broken on Milestone/Droid?

I'm using the stock android.R.anim.fade_in animation to fade in a
textview. Here's the code to reproduce:

    @Override
    public void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);

        Animation fadeInAnim = AnimationUtils.loadAnimation(this,
android.R.anim.fade_in);
        fadeInAnim.setDuration(10000);

        LinearLayout r = (LinearLayout)findViewById(R.id.root);
        TextView text = new TextView(this);
        text.setText("Hello World");
        text.setTextColor(Color.BLACK);
        r.addView(text);

        text.startAnimation(fadeInAnim);
    }

The Layout:

    <?xml version="1.0" encoding="utf-8"?>
    <LinearLayout xmlns:android="http://schemas.android.com/apk/res/
android"
        android:orientation="vertical"
        android:layout_width="fill_parent"
        android:layout_height="fill_parent"
        android:id="@+id/root"
        android:background="#FFFFFF">
    </LinearLayout>

This works wonderfully on the ADP1, the emulator in various versions,
but on a 2.0 Milestone, for the whole time the animation is running,
the background of the textview is visible in very light grey/blue
color.

Note that in the code above, the TextView background color is
transparent, on the activity background is set to something non-
default. If either of those are not true, the problem doesn't occur.
For example, if I set the TextView background to white also, I don't
see the artifact; same if I leave the activity background at the
default,

Is this a bug? Can other Milestone/Droid owners confirm this?

-- 

3. AltGr support

4. now there is an ant clean target

5. Background on layout is scrunching contained content

6. Affordable Outsourcing in the Philippines

7. App2sd di N1 untuk cyanogen rom