Reg Java 6 issue with ubuntu 9.1

by Karthik P » Thu, 19 Nov 2009 02:05:32 GMT


Sponsored Links
 Hi,

I recently installed ubuntu 9.1 in my system which had java 6 installed. I'm
unable to build Android on my system due to Java version mismatch. Hence I
tried to download jdk5 but packages are not available thru synaptics package
manager. Can anyone help me in this regard?

Karthik

-- 



Reg Java 6 issue with ubuntu 9.1

by Misael Lopez » Thu, 19 Nov 2009 02:35:02 GMT


 Ubuntu 9.10 doesn't include jdk5, but you can add the source list
entry from 9.04 (Jaunty).

1. Append the two lines shown below to your /etc/apt/source.list:
deb  http://us.archive.ubuntu.com/ubuntu/ jaunty multiverse 
deb  http://us.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse 

2. Retrieve new source lists:
    sudo apt-get update

3. Then you can download jdk5
    sudo apt-get install sun-java5-jdk

-Misa

2009/11/18 Karthik P <karthi...@gmail.com>:

-- 


Sponsored Links


Reg Java 6 issue with ubuntu 9.1

by Karthik P » Fri, 20 Nov 2009 15:23:42 GMT


 Thanks Misa, that worked but now I'm facing a build issue.

target Java: GoogleSearch
(out/target/common/obj/APPS/GoogleSearch_intermediates/classes)
packages/apps/GoogleSearch/gen/com/android/googlesearch/R.java:10: duplicate
class: com.android.googlesearch.R
public final class R {
             ^
1 error
make: ***
[out/target/common/obj/APPS/GoogleSearch_intermediates/classes-full-debug.jar]
Error 41

Any help in this regard will be of great help.

Karthik




> > website: 



Other Threads

1. determine the cache size for bitmaps

Dear,

I manage a cache of bitmap.
Do you have an advise to fix the maximum size of it ?

Regards,

Olivier

-- 

2. Any api for mapview callout/bubble for tapped pins?



Nothing built in.


Biggest challenge is in figuring out the placement relative to the
point, taking into account the desired size of the bubble. For the
book sample I did for this, I cheated and had popup panels just on
either the top or bottom of the screen, shown on the side opposite
that of the point itself.

-- 
Mark Murphy (a Commons Guy)
http://commonsware.com | http://github.com/commonsguy
http://commonsware.com/blog | http://twitter.com/commonsguy

_The Busy Coder's Guide to *Advanced* Android Development_ Version 1.6
Available!

-- 

3. Any chance to deactivate the lock pattern in Froyo from code?

4. Best way to change text styles in a list? (performance)

5. adb is broken after upgrade to Froyo

6. legend VS x1

7. Ringtone