process closing unexeptedly in emulator

by aditya.kulkarni » Tue, 21 Apr 2009 01:37:32 GMT


Sponsored Links
 hi all,
i tried to write a SOAP application where a .net server is running a
method Add in local host and returns an integer value 2000
here is the code for android to connect to local server via SOAP
import android.app.Activity;
import android.os.Bundle;
import android.view.View;
import android.widget.Button;
import android.widget.TextView;
import java.*;


import org.ksoap2.SoapEnvelope;
import org.ksoap2.serialization.SoapObject;
import org.ksoap2.serialization.SoapSerializationEnvelope;
import org.ksoap2.transport.HttpTransportSE;


     public class Test extends Activity {
          private Button okButton;

           private int a;
          private static final String SOAP_ACTION = "http://
10.0.2.2:8000/target.asmx/Add";
          private static final String METHOD_NAME = "Add";
          private static final String NAMESPACE = "http://
tempuri.org";
          private static final String URL = " http://10.0.2.2 :8000/
target.asmx";

         @Override
         protected void onCreate(Bundle icicle) {
             super.onCreate(icicle);
             setContentView(R.layout.main);


            okButton = (Button) findViewById(R.id.but);
             okButton.setOnClickListener(new View.OnClickListener() {

                 public void onClick(View view) {
                  //   setResult(RESULT_OK);

                     a= mymethod();

                 }
             });
             TextView tv=new TextView(this);
             tv.setText(a);
             setContentView(tv);

         }
         public static int  mymethod() {
           SoapObject request = new SoapObject(NAMESPACE,
METHOD_NAME);


           SoapSerializationEnvelope envelope = new
SoapSerializationEnvelope(SoapEnvelope.VER11);
           envelope.dotNet = true;
           envelope.setOutputSoapObject(request);
           HttpTransportSE androidHttpTransport = new HttpTransportSE
(URL);
           int a=0;

           try {
                androidHttpTransport.call(SOAP_ACTION, envelope);
                  a=(Integer)envelope.getResponse();
           } catch (Exception e) {
                e.printStackTrace();
           }
         return a;


         }
     }

when trying to run in emulator giving error as "PROCESS STOPPED
UNEXCEPTEDLY".....please tell me where is the mistake..... thank you
in advance..

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Find the location in Android Map

Hello 2 All,

I m working on my one application in that user have to put latitude
and longitude of the location and after pressing the button the map
shows that location.

I have a problem in that.

Can anyone help me to solve it out?

~Dhr

-- 

2. Uploading file through HTTP Post

Hi All,

I am writing an application to upload a file from Android phone to a
web server.

I have tried the example from:

http://www.anddev.org/novice-tutorials-f8/doing-http-post-with-android-t492.html

But it will only work for SDK 1.0 (why? Not Sure?).

Can this be done for Android 2.1? Or is there any other method to load
a file from Android to a webserver?

Thanks In Advance,
Perumal

-- 

3. about video capture!!!

4. Formal Android training

5. Media URI stability

6. Ramdisk image

7. Failed to open /dev/msm_pcm_out for writing