Help! Problem with DDMS Location Controls !!

by rocia » Fri, 06 Mar 2009 16:43:51 GMT

Sponsored Links
 hi, Mark
   I'm sorry , the image is as follows; !9D96EEC35DE1E477!6071.entry
   I can't access the web of . Thank 
you for your reply and waiting for your reply!


Help! Problem with DDMS Location Controls !!

by Mark Murphy » Fri, 06 Mar 2009 20:49:49 GMT


OK, here are the two most likely discussion lists for somebody who is
building Android from source:

Android platform (

Sponsored Links

Other Threads

1. debugging the (suddenly) crippling slowness of the emulator

(aside:  my apologies for the regular posting of newbie-level
questions -- i'm just trying to stress test stuff as i learn it so
it's not surprising that i'll{*filter*}something up and need help to fix
it.  also, hysterically, with what little i know so far, i've been
asked to give a beginner-level tutorial locally on how to get started
with android.  the mind reels.  anyway, onward if i might ...)

  curiously, since just yesterday when i ran the emulator on my ubuntu
10.04 system and it worked relatively quickly, this morning, bringing
up a new AVD that i just created (nothing special about it) is taking
*forever* -- literally, it's been 10 minutes since i started the
emulator and i'm still looking at the boot animation screen.

  is there a way to debug what's going on?  i've already verified that
not long after i start the emulator, "adb devices" sees it and i can
"adb shell" into it.  some time after that, what i assume is the
"bootanimation" utility starts to run which produces the neat
"android" boot logo and ... much more time passes.

  during this time, i'm shelled into the emulator, "ps" works (i can
see the "bootanimation" utility running), "top" works, things are
clearly running but i have no idea why, just in the last several
hours, things are so much slower.  this is an absolutely stock AVD (1G
SD card), no added apps, etc.  it's the same thing i was testing
previously with no issues.

  given that i can shell into the emulator and poke around, is there
something i can check?  at this point, i'm baffled.

User 43%, System 32%, IOW 0%, IRQ 1%
User 85 + Nice 0 + Sys 64 + Idle 44 + IOW 0 + IRQ 3 + SIRQ 0 = 196

  PID CPU% S  #THR     VSS     RSS PCY UID      Name
  186  54% S    18 122508K  24064K  fg system   system_server
  147  18% R     1    912K    396K  fg root     top
  196   9% S     4  12772K   5148K  fg graphics /system/bin/bootanimation
   40   1% S     4   3388K    176K  fg root     /sbin/adbd
  ... snip ...


Robert P. J. Day                               Waterloo, Ontario, CANADA

            Linux Consulting, Training and Kernel Pedantry.

Web page:                                           http://www.***.com/ 
Twitter:                                        http://www.***.com/ 


2. Get Notified when a new access point is added?

Would using NETWORK_IDS_CHANGED_ACTION be an option?


3. Test on CM 05

4. Camera Milestone Cras

5. SampleSyncAdapter doesn't show up in list of Content Providers

6. Aps buat facebook chat dan Aps Yahoo messenger

7. How to get current timezone when user has selected "use network-provided values"