ERROR: Application requires API version 2. Device API version is 1

by JP » Fri, 29 May 2009 10:33:39 GMT

Sponsored Links
 You're running Android 1.0 on the device, which is API version 1.
Unless you think your target audience is still on 1.0 for one reason
or another, I'd recommend you update your device to at least 1.1, or
better yet, straight to 1.5. They have version numbers 2 and 3
Now if you absolutely need to cover 1.0, you have to drop
minSdkVersion to 1.


Other Threads

1. How to install Thawte EV Root Cert onto Android

Our Exchange server has one of the Thawte EV SSL certs (turns the
address bar green), It appears when I try to use the ContactSync
program for the Exchange Web Services (EWS) it won't connect. When I
try via the android browser it warns me about no being able to verify
the Thawte intermediate cert. Which makes me think the Android browser
doesn't know where to get the EV root cert from either and is why I
can't connect to the system via ContactSync.

 Anyone know if there's a way to install the cert onto the phone? Or
anyone else experience this SSL chained cert issue?


2. Looking for Developer Partner

I am looking for an experienced Developer to help me in developing an
exciting new application for Google Phone users. It encompasses a
widely used application currently limited to traditional laptop or
desktop computing environments that would have a huge market for
mobile, handheld users. With a large built in market, the challenge is
simply in the engineering of a Google phone-compatible version. I am
not a techie. Who can help?



3. sql plus 10G

4. Terminating an application?

5. is ACTION_WEB_SEARCH removed from the SDK?

6. ASUS skin now available for Android Emulator!

7. why would android call oncreate when flipping the keyboard