java issues in mac and window

by dadada » Sun, 12 Sep 2010 13:24:41 GMT


Sponsored Links
 hi all,


So i opened my android project(from win7 environment) in my mac.

then i have these java problems :

@Override
                public void onFocusChange(View v, boolean hasFocus) {
                        // TODO Auto-generated method stub

                }



@Override
            public void onLocationChanged(Location location) {


        @Override
                public void onClick(View v)
                        {



removing those @override notation solve the issues. why is this
happening in the first place?

who is right? mac or window

thanks!

--



java issues in mac and window

by Frank Weiss » Sun, 12 Sep 2010 15:53:48 GMT


 Which JDK version do you have installed on the Mac? Which JDK version is the
tool that had "issues" using?

--


Sponsored Links


Other Threads

1. How to display unicode text received from a web API

Hello,

I'm fetching some data from my web API that returns XML with content
which includes escaped unicode characters. So there is content such as
"Izložba" which I need to display in a TextView as word
"Izloba". How can I do this? Right now these characters are either
ommitted or displayed as that raw escaped value.

-- 

2. SharedPreferences can not create the xml file

Hi
I have been trying to fix this problem for 3 days now and still no
luck. I am trying to save some preferences of my app (just a few
integers and strings), but I notice that SharedPreferences never
creates any xml file. So far I have tried the followings:
1) In my AndroidManifest, I set Persistent to true.
2) To be more cautious, my preference file is all lower case, even
though I did not think it was necessary.
3) Interestingly enough edit().commit() returns true, but I do not see
the xml file anywhere in my computer. And when I try to read the
values from the preferences, I get the default values that I have in
my getInt() or getString().
4) I ran my app in the de{*filter*} and I saw no errors in the log related
to this.
5) I tried running it in 2 different emulator running Android 1.5 and
2.0, same result.

Here is a gist of my code:
        SharePreferences x = this.getSharedPreferences
(Configuration.PREFFILE, Context.MODE_PRIVATE);
        int level = x.getInt(LEVEL, 1);
        ..........
        x.edit().putInt(LEVEL, level);
        if ( !x.edit().commit() )
                Log.e(Configuration.TAG, "setLevel failed to commit");

I can not think of any reason that causes this. Any help is greatly
appreciated.
Thanks



-- 

3. Example for Contacts.PresenceColumns

4. BitmapFactory.decodeByteArray gives pixelated bitmap

5. TableLayout set column width by using layout_weight

6. RelativeLayout algorithm.

7. Using bitmap data to copy pixels to a new bitmap