Problem facing during start a android project through eclipse

by Prashant-LAMP » Thu, 18 Sep 2008 18:07:30 GMT


Sponsored Links
 I am getting the following error in eclipse :

Plug-in com.android.ide.eclipse.adt was unable to load class
com.android.ide.eclipse.adt.project.NewProjectWizard.
An error occurred while automatically activating bundle
com.android.ide.eclipse.adt (156).
Can you please help to find out the problem.

- Prashant Rahulkar



--~--~---------~--~----~------------~-------~--~----~



Problem facing during start a android project through eclipse

by Gav » Thu, 18 Sep 2008 21:00:00 GMT


 Can you provide more info?

OS/JDK/android SDK version/Eclipse?

When does it occur? Have you setup the SDK path?




--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Problem facing during start a android project through eclipse

by hongqing huang » Sun, 21 Sep 2008 19:34:52 GMT


 My suggestion is get the Eclipse version higher than 3.3

2008/9/19 Gav <[EMAIL PROTECTED]>



--~--~---------~--~----~------------~-------~--~----~



Problem facing during start a android project through eclipse

by Prashant-LAMP » Fri, 26 Sep 2008 17:42:32 GMT


 OS - Fedora 5
JDK 1.5
Eclipse SDK
Version: 3.3.2







--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. help with my installation ADT and SDK in eclipse

Hi everyone
my eclipse version eclipse-java-ganymede-SR1-linux-gtk.tar.gz
my sdk version:android-sdk-linux_x86-1.0_r1.zip 
AND i think i have followed the steps in authority google website to install 
ADT.
and I think I have successfully set the SDK path in eclipse following the 
google website.
I have added environment variable in file ~/.bashrc as following:
PATH=$PATH:/opt/bin
export PATH
PATH=$PATH:/opt/android-sdk-linux_x86-1.0_r1/tools
export PATH
PATH=$PATH:/opt/eclipse
export PATH

but although I can successfully start eclipse , when I set a new android 
project, error occurs. it pops up a window to inform me that:
Failed to get the required ADT version number from the SDK.
And android Toolkit may not work properly.

and the console window in eclipse shows:
[2009-02-20 09:41:27 - Android Framework Parser] Menu declare-styleable Menu 
not found in file 
/opt/android-sdk-linux_x86-1.0_r1/tools/lib/res//default/values/attrs.xml
[2009-02-20 09:41:27 - Android Framework Parser] Menu declare-styleable 
MenuItem not found in file 
/opt/android-sdk-linux_x86-1.0_r1/tools/lib/res//default/values/attrs.xml
[2009-02-20 09:41:27 - Android Framework Parser] Menu declare-styleable 
MenuGroup not found in file 
/opt/android-sdk-linux_x86-1.0_r1/tools/lib/res//default/values/attrs.xml
[2009-02-20 09:41:27 - Android Framework Parser] Searchable declare-styleable 
Searchable not found in file 
/opt/android-sdk-linux_x86-1.0_r1/tools/lib/res//default/values/attrs.xml
[2009-02-20 09:41:27 - Android Framework Parser] Searchable declare-styleable 
SearchableActionKey not found in file 
/opt/android-sdk-linux_x86-1.0_r1/tools/lib/res//default/values/attrs.xml
[2009-02-20 09:41:27] Warning, ADT/SDK Mismatch! The following elements are 
declared by ADT but not by the SDK: manifest
[2009-02-20 09:41:27 - Framework Resource Parser] Failed to parse

I am using ubuntu 8.10, and using the terminal to start the eclipse, and also 
the terminal shows :Error Loading Preferences
Exception in thread "Ping!" org.eclipse.swt.SWTError: Not implemented [multiple 
displays]
    at org.eclipse.swt.SWT.error(SWT.java:3803)
    at org.eclipse.swt.widgets.Display.checkDisplay(Display.java:712)
    at org.eclipse.swt.widgets.Display.create(Display.java:842)
    at org.eclipse.swt.graphics.Device.<init>(Device.java:154)
    at org.eclipse.swt.widgets.Display.<init>(Display.java:471)
    at org.eclipse.swt.widgets.Display.<init>(Display.java:462)
    at com.android.ping.PingService.getUserPermission(PingService.java:278)
    at com.android.ping.PingService.ping(PingService.java:126)
    at com.android.ide.eclipse.common.PingHelper.pingUsageServer(Unknown Source)
    at com.android.ide.eclipse.adt.AdtPlugin$10.run(Unknown Source)

has any one met the problem ?



--~--~---------~--~----~------------~-------~--~----~

2. SDK 1.1_r1 javadoc issue is fixed.

Hello everyone,

The 1.1 SDK we released last week includes a new design for the
documentation. Unfortunately, the new design changed the HTML in a way that
made Eclipse unable to parse the files.

We've fixed the issue and put up new SDK archives for download.

Sorry for the inconvenience.

Xav
-- 
Xavier Ducrohet
Android Engineer, Google.

--~--~---------~--~----~------------~-------~--~----~

3. Gradient Questions

4. AddDataSink & custom MIO Decode Node

5. help with my installation ADT and SDK in eclipse

6. Touchscreen Driver Issues on PXA platform