Can't open dex cache error with SDK 1.1

by loty » Thu, 05 Mar 2009 07:03:00 GMT

Sponsored Links
 Recently I switched to SDK 1.1 and it worked for a short time without
any problems. Now I'm getting "Can't open dex cache '/data/dalvik-
cache/system ..." error and emulator doesn't start at all. Just shows
Android screen of death with blinking cursor. When I repoint Eclipse
back to 1.0 r2 it works fine.

I did adb shell and /data folder is empty


Can't open dex cache error with SDK 1.1

by fadden » Thu, 05 Mar 2009 09:52:17 GMT


The /data/dalvik-cache directory is created by init when the system
boots.  From system/core/rootdir/init.rc:

    # create dalvik-cache and double-check the perms
    mkdir /data/dalvik-cache 0771 system system
    chown system system /data/dalvik-cache
    chmod 0771 /data/dalvik-cache

Does "mount" show that you have a filesystem mounted on /data, or is
it just an empty mount point?  I'm guessing the latter.


Sponsored Links

Other Threads

1. move over touch event


I need to detect the element the user's finger is over as long as he
moves it over the screen. Then i want to extract this element to
process it.

Is it possible? I tried using getHitTestResult(), but it only works
with hits not with move.. any idea?



2. ambil apk dari aplikasi yg sdh diinstall di hero.

guyss ....

short story : ada nggak cara untuk ambil file apk dari aplikasi yg sdh di install di hero ? long-story : saya punya aplikasi dbms pada hero saya. aplikasi ini saya ambil dari market duluuuuuuu. sekarang di market sdh nggak ada lagi aplikasi tsb. nah ... saya kepikiran untuk ambil file apk ... directly from my hero. Ada nggak cara nya ? how ? help meeeee -- -------------- "Indonesian Android Community [id-android]"

3. Auto correct fail on soft keyboard

4. pppd dns problem

5. Zeppelin

6. Upgrade ROM Magic

7. Data access during a phone call on the emulator