show error "I/ddms: Ping not sent: too soon after last"

by Bruce » Wed, 25 Jun 2008 19:17:37 GMT


Sponsored Links
 Hi everyone.

I am just using jdk1.6.0_06, Android-SDK_m5_rc15_windows on Windows
XP. Whenever I run the "Hello World" sample, a popup prompt display "I/
ddms: Ping not sent: too soon after last". The emulator also display
but not working. After a few minutes, the emulator display
"Application is not responding. Force Quit/Wait".

The program can be compiled in the bin directory (generated both class
and apk file). This problem is related to the DDMS debugger.
Anyone can help to solve this problem?

Bruce

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Error playing YouTube video in my application

I'm trying to play streaming video(*.3gp) with android SDK 1.5 pre.
I have customized the APIDemo -> VideoViewDemo.java.
Specify the "path" to the URL of rtsp.
I got the URL from the following URL.
--http://gdata.youtube.com/feeds/api/videos?vq=8ZsML4uWoiw
I used the following URL(*.3gp)
--
path = "rtsp://rtsp2.youtube.com/
CiILENy73wIaGQksopaLLwyb8RMYDSANFEgGUgZ2aWRlb3MM/0/0/0/video.3gp"

But following error has occur.
Please help me what is happen.

----
04-27 07:10:24.238: WARN/ActivityManager(587): Launch timeout has
expired, giving up wake lock!
04-27 07:10:24.265: WARN/ActivityManager(587): Activity idle timeout
for HistoryRecord{43603ba0 {com.example.android.apis/
com.example.android.apis.media.VideoViewDemo}}
04-27 07:10:27.975: ERROR/PlayerDriver(972): HandleInformationalEvent:
type=28 UNHANDLED
04-27 07:10:28.584: WARN/PlayerDriver(972): Using generic video MIO
04-27 07:10:44.975: ERROR/PlayerDriver(972): Command PLAYER_PREPARE
completed with an error or info PVMFFailure
04-27 07:10:44.985: ERROR/MediaPlayer(1095): error (1, -1)
04-27 07:10:44.995: ERROR/MediaPlayer(1095): Error (1,-1)
04-27 07:10:45.515: WARN/PlayerDriver(972):
PVMFInfoErrorHandlingComplete
----

I have confirmed the local *.3gp file is enable to play with this
code.
path = "/sdcard/747.3gp"

--~--~---------~--~----~------------~-------~--~----~

2. SDK1.5 AudioRecord sample rate problem

I was trying to record sound using the MIC with the AudioRecord class:

mRecord = new AudioRecord(
                        MediaRecorder.AudioSource.MIC,
                        SAMPLE_RATE,
                        AudioFormat.CHANNEL_CONFIGURATION_DEFAULT,
                        AudioFormat.ENCODING_DEFAULT,
                        BUFFERSIZE
                        );

This call results in:

ERROR/AudioRecord(1120): Recording parameters are not supported:
sampleRate 11025, channelCount 1, format 1
ERROR/AudioRecord-JNI(1120): Error creating AudioRecord instance:
initialization check failed.
ERROR/AudioRecord-Java(1120): [ android.media.AudioRecord ] Error code
-20 when initializing native AudioRecord object.

whenever the SAMPLE_RATE is some value other than
AudioRecord::DEFAULT_SAMPLE_RATE (8000) declared in ./frameworks/base/
include/media/AudioRecord.h from GIT.
The documentation says 11025/22050/44100 should be ok too.

Am I missing something?

Thank you for your help,

-Szabolcs

--~--~---------~--~----~------------~-------~--~----~

3. how can i open the jd file under developments/pdk/docs

4. Why corsor need to call setNotificationUri when query from content provider?

5. why no Horizontal GridView/ListView ?

6. Compiling against a *REAL* android.jar in eclipse???

7. G1 detected as 'offline' by Eclipse plugin