"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by hc » Mon, 27 Apr 2009 21:46:16 GMT


Sponsored Links
 Hi,

I just tried that. But it does not work. After removing the file, I
still get the same error when I try to compile for 1.1 SDK.

Worse, when I try to compile for 1.5 SDK after that, I get the
following error but application compiled successfully
Conversion to Dalvik format failed with error 1



On Apr 27, 9:05pm, Satya Komatineni <satya.komatin...@gmail.com>



--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by Jay lee » Tue, 28 Apr 2009 11:03:25 GMT


 I saw the same error.
so I reinstalled ADT and recheck build target "Android1.1"
then I can see R.java which is generated at "gen" folder.

try this.






--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by hc » Tue, 28 Apr 2009 12:49:27 GMT


 Do you have to uninstall before you reinstall it? I just updated my
ADT to 0.9 (the non-pre ADT), and update to 1.5_R1 SDK, but I still
get the same error if I try to compile for Android1.1






--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by hc » Tue, 28 Apr 2009 15:09:16 GMT


 How do u add tools directory to PATH? Was that automatic in Eclipse,
and I broke that somehow?

On Apr 28, 1:56pm, Andr Charles Legendre <andre.legen...@gmail.com>


--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by Richard Schilling » Fri, 01 May 2009 05:10:13 GMT


 I had the same problem but solved it.  Perhaps this will help:  Make
sure the 'gen' directory is part of the java source build path.

Right Click on project name (Package Explorer) -> Properties (Context
Menu) ->
Java Build Path (tree) -> Source (tab) -> Add Folder (Button) ->
"gen" (directory name)
-> OK (BUtton)

Now R will be properly resolved.

Richard Schilling
Root Wireless, Inc.



--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 05:54:58 GMT


 I have the same problem i.e. after converting to Android 1.5 SDK,
my project files won't compile due to dozens of R.* files "cannot be
resolved".

I've tried:
   1. Adding the sdk 'tools' to my path
   2. Reinstalling ADT
   3. Cleaning my project

Nothing is working. Anyone have any other suggestions. I'm stopped.

jh








--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 06:48:30 GMT


  also checked and the 'gen' dir is in my java source build path.
Its still not working.

jh

On Apr 30, 2:54pm, "John B. Hansen" <jnahan...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 10:07:25 GMT


 es, I selected Android 1.1 platform API Level 2.
I also made sure src and gen folders were included in the Build path.
I also included res folder in Build path but it had no effect.

FYI: I am able to build a new Hello World program that just works.
But,
I can't figure out why that one works and my migrated projects don't
work?

jh

On Apr 30, 5:24pm, Xavier Ducrohet <x...@android.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 21:31:52 GMT


 trange. When I manually deleted all the Import statements and then
Reorganize Imports (Shift+Ctrl+O) again, it cleans up the problems. I
had been
using Organize-Imports (Shift+Ctrl+O) repeatedly on those migrated
files but there may have been some stale imports that needed to be
manually deleted (I thought Organize-Imports would do that
automatically for me? but
apparently not?). Anyway, I'm cleaning up the files using this method
and it works
for both 1.1 and 1.5 build targets. Looks like this is solved. Thanks
for the
assistance.

jh

On Apr 30, 7:07pm, "John B. Hansen" <jnahan...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 21:38:09 GMT


 ore info...it is specifically the "import android.R" statement that
is
causing the problem. It was in all my old files. When I delete it and
re-generate
the new imports, the problem goes away.

Maybe this can be fixed in Eclipse or ADT. I'm sure other people must
also
be having this problem.

jh

On May 1, 6:31am, "John B. Hansen" <jnahan...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 21:38:14 GMT


 ore info...it is specifically the "import android.R" statement that
is
causing the problem. It was in all my old files. When I delete it and
re-generate
the new imports, the problem goes away.

Maybe this can be fixed in Eclipse or ADT. I'm sure other people must
also
be having this problem.

jh

On May 1, 6:31am, "John B. Hansen" <jnahan...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by John B. Hansen » Fri, 01 May 2009 21:57:53 GMT


 ore info...it is specifically the "import android.R" statement that
is
causing the problem. It was in all my old files. When I delete it and
re-generate
the new imports, the problem goes away.

Maybe this can be fixed in Eclipse or ADT. I'm sure other people must
also
be having this problem.

jh

On May 1, 6:31am, "John B. Hansen" <jnahan...@gmail.com> wrote:
--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by pis4vlg » Thu, 07 May 2009 05:26:55 GMT


 I think this is the right answer. When face the same problem, I fixed
it after clean the project.

thanks to Raphael

vincent









--~--~---------~--~----~------------~-------~--~----~



"R cannot be resolved" after updating to 1.5 SDK Pre, and trying to compile for 1.1

by Michael » Thu, 14 May 2009 01:25:00 GMT


 'm running fedora 10, and I've had similar issues.  Cleaning is part
of the solution. However, I had a further problem that needed to be
resolved first. As with previous releases of the SDK, I've found that
I needed to execute "chmod 755 *" in the 'tools' directory. With this
release, there are 2 additional 'tools' directories that need to have
the proper permissions set (via the same command). These are under
the 'platforms' directories, .../android-sdk-linux_x86-1.5_r1/
platforms/android-1.1/tools and .../android-sdk-linux_x86-1.5_r1/
platforms/android-1.5/tools. Hope this helps someone.

On May 6, 9:20am, pis4vlg <pis4...@gmail.com> wrote:

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Dream jadi lemot

Guys.......

Koq jd lemot ya,padahal dah ganti class6 (8gb) ,tdnya malah class 2/4 merk
vgen 4gb gak gitu lemot
Ini dah pake app utk speed cpu walau max jg cuma 525

awal mula 4gb dgn amonra 1.2.3 eclair 2.1 kingklick, trus update amonra
1.5.1 , update  lg amonra 1.5.2 ,baru ganti microsd class6 8gb ,sebelumnya
backup&restore dgn nand+__ext

~ white dream ~

-- 
"Indonesian Android Community [id-android]" 

2. my FileDescriptor doesn't work with mediaplayer (plz help)

Hi Experts,

i have a filedescriptor through a script like this
------------------------------------------------------------
Class<?> execClass = Class.forName("android.os.Exec");
                    Method createSubprocess =
execClass.getMethod("createSubprocess",
                            String.class, String.class, String.class,
int[].class);
                    Method waitFor = execClass.getMethod("waitFor",
int.class);

                    // Executes the command.
                    // NOTE: createSubprocess() is asynchronous.
                    int[] pid = new int[1];
                  FileDescriptor   fd =
(FileDescriptor)createSubprocess.invoke(
                            null, "/system/bin/cat", "/sdcard/chunk.3gp",
null, pid);
------------------------------------------------------------

i can read bytes from fd and it seems working fine but when i pass it
to the mediaplayer as datasource.
it doesn't show anything. (this is just 1 sec video)
same video works fine with direct path but i need to decrypt the file
bytes by bytes while its playing.
i thought this solution might help me but no luck so far.
can anybody guide me to the right direction how can i decrypt the file
while playing ?
or do i need to change in native code and build the opencore (pv
player ) separately and any change in there?

please help

--

3. Mirink Bandung (Android Developer)

4. Just info Milestone

5. NexDesire_remix

6. Ga bisa download dari market setelah di root! apa ada pengaruhnya?

7. How to customize onscreen keyboard? Please help!