2.1 Bluetooth support still needs work

by Anders Widen » Tue, 20 Apr 2010 20:28:45 GMT

Sponsored Links

I've been working with bluetooth trying figure things out using the
BTChatExample. Without editing BTChat has errors that destroy the
functionality. You can only connect the first time, if you connect.
Close the program and doesn't restart bluetooth the program crashes.
Even if you edit out the AccepThread and only focus on client connect,
the program will cast exceptions.

"JBtlSpp.create failed with status FAILED"

when trying to connect. I've looked into the code and referenced it
with the docs (that are based around the ChatExample) and either
bluetooth still needs work or there something missing in the APIs.

I would love to hear from other people trying to use Bluetooth on
Android 2.0++, or try to get a hold of a framework developer to try to
iron out these that I believe are in the framework itself.


2.1 Bluetooth support still needs work

by Max Gilead » Tue, 20 Apr 2010 21:07:06 GMT

 Hi Anders!

You can search list archives for others with BT-related issues. I for one am
having problems with it too (Droid with 2.0.1 firmware, still waiting for
OTA 2.1 update).

When every other phone/laptop I tried can connect to a device and even my
Droid can connect to is using low-level driver but it's plain impossible
from application level I'd say we have a bug here (full story @

Philipp's thread:

Sponsored Links

2.1 Bluetooth support still needs work

by ssozonoff » Tue, 20 Apr 2010 21:48:20 GMT


Yes I can confirm the same.

I have a solution working for example under the HTC Legend but fails
using the HTC Desire and the failure apears to be at a fairly low



2.1 Bluetooth support still needs work

by DonFrench » Wed, 21 Apr 2010 03:43:43 GMT

 I have a similar problem and I suspect a timing problem.  In my case,
I have two seemingly identical devices and my Android Bluetooth app
can connect to one of them but not the other.  Both devices use the
same serial Bluetooth radio and everything else about the two devices
is identical.  I know this because I manufacture the devices.
Although my 2.1 Android app can only connect to one of these, my
Windows Mobile app can connect to both of them with equal ease.  The
only thing  that I can think that might be different is that maybe one
of the two devices takes slightly longer to respond to a connection
request and that the Android software simply gives up too soon.

> >

2.1 Bluetooth support still needs work

by Anders Widen » Wed, 21 Apr 2010 15:19:07 GMT

 I can connect to my PC and send and receive messages using SPP and a
terminal program. But restarting doesn't work and the connect doesn't
always work either:

1. Restarting (connecting) the program doesn't work without restarting
BT (Closing BTStack fails somewhere)
2. Sometimes when connecting, phone reads strings of length -1 and
loops a lot of output at Logcat about this.
3. When trying to connect to a bonded device the device name shows up
as "null". (After a restart of the program, guess it's related to 1.)

Anyone solved this issues?


Other Threads

1. Parsing &#xx; characters in XML

Hi all,

I'm using a DOM parser to parse XML from Google News. Unfortunaltly,
the XML is full of ' characters and the parser cannot deal with
them properly. Is there any way to achieve parsing correctly? Am I
missing something?


2. Cannot find /sys/class/power_supply/ac/online

      I've ported the android-2.6.29 kernel to the Overo linux-
omap3-2.6.29 kernel version. The android logo boots up, and after
sometime, the system shuts down.

When I look in the find /sys/class/power_supply folder, I don't see
anything. I have enabled CONFIG_POWER_SUPPLY=y in my defconfig.

What could be going wrong? Why are the required devices not being

Best regards,


I/SystemServer(  865): Starting Battery Service.
E/BatteryService(  865): Could not open '/sys/class/power_supply/ac/
E/BatteryService(  865): Could not open '/sys/class/power_supply/usb/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/
E/BatteryService(  865): Could not open '/sys/class/power_supply/

unsubscribe: android-porting+unsubscr...@googlegroups.com

3. Anyone been asked by dev to change their rating for their app on market?

4. How to analyze memory usage of your Android application

5. Android Market: Can you download apps without publishing them? Do you pay for your own apps? +signing problems

6. Early Look Android 1.5 SDK

7. Idea of making typing efficient and easy on phones with screen keyboard