How to launch YouTube with specified keywords?

by Kumar Bibek » Thu, 11 Mar 2010 13:14:05 GMT


Sponsored Links
 Try this.

Intent intent = new Intent(Intent.ACTION_SEARCH);
intent.putExtra("query", "Android");
intent.setFlags(Intent.FLAG_ACTIVITY_NEW_TASK);
startActivity(intent);

Here, you will get a Chooser activity. Now when you select Youtube,
you will get video results for Android.

Thanks and Regards,
Kumar Bibek




--



How to launch YouTube with specified keywords?

by Kumar Bibek » Thu, 11 Mar 2010 20:01:47 GMT


 This works

Intent intent = new Intent(Intent.ACTION_SEARCH);
intent.setPackage("com.google.android.youtube");
intent.putExtra("query", "Android");
intent.setFlags(Intent.FLAG_ACTIVITY_NEW_TASK);
startActivity(intent);


Thanks and Regards,
Kumar Bibek.




--


Sponsored Links


How to launch YouTube with specified keywords?

by Kumar Bibek » Thu, 11 Mar 2010 20:12:02 GMT


Other Threads

1. Passing arguments to JSON c# .net web service

Hello,
i searched the net to find something about how to pass arguments to
JSON c# .net web service, but i didn't find anything useful for me. I
have to pass arguments like GUID or at least Username and Password.
Is
params.put("var", ""); the right thing? How do i pass multiple
parameters like this, let's say username and password?




Regards,
Tadej

-- 

2. Bundle.putIBinder is deleted

Hi,

I need pass a Binder object to another process via Message, in Android 2.1,
the code like below:

Bundle b = new Bundle();
b.putIBinder("KEY_BINDER", new Binder());
message.setData(b);
mService.send(message);

It works well in Android 2.1. However, the API putIBinder() is deleted in
Android2.2.
So what's the replace way?  Because the communication is based message
mechanism,
I don't want to go to back to use AIDL.

Thanks in advance.

-- 

3. how to control the bitmap rotate base on the touch position?

4. Running multiple activities in for loop one after the other - android

5. Emulator with iMx specific images.

6. TextView:autoLink="all" + textAppearance bug?

7. GalleryView Bug???