Can't get adb shell to connect to real M912

by Chris Doherty » Fri, 14 Aug 2009 01:41:07 GMT


Sponsored Links
 Okay, I have Android built from the android-x86 source tree (http://
code.google.com/p/android-x86/) using the instructions on the wiki
there.  The only change I've made from the default is the addition of
the M912 touchscreen patch from the M912 Android patches project
( http://code.google.com/p/android-m912/ ).

Android is installed and booting from the hard drive on a real
Gigabyte M912 netbook.  The ethernet port is working and has received
an IP address successfully from a DHCP server.  I have Windows Vista
machine on the same subnet; that Windows Vista machine is running
Ubuntu 8.04 in a VMware Server 2.0 virtual machine.  Both Windows
Vista and the Ubuntu VM have the 1.5r3 SDK installed.

I can't get adb to connect to and run a shell on the M912 using adb
over Ethernet.  The M912 can ping both the Vista machine and the
Ubuntu VM by IP; both the Vista machine and the Ubuntu VM can ping the
M912 by IP.

When I try to connect to the adb on the M912, however the following
happens:

Vista machine:
C:\android-sdk-windows-1.5_r3\tools>set ADBHOST=xx.xx.xx.xx
C:\android-sdk-windows-1.5_r3\tools>adb kill-server
C:\android-sdk-windows-1.5_r3\tools>adb devices
* daemon not running. starting it now *
* daemon started successfully *
List of devices attached
emulator-5554   device

C:\android-sdk-windows-1.5_r3\tools>adb shell
- exec '/system/bin/sh' failed: Bad address (14) -

C:\android-sdk-windows-1.5_r3\tools>adb -s emulator-5554 shell
- exec '/system/bin/sh' failed: Bad address (14) -

ch...@marvin:~/android-sdk-linux_x86-1.5_r3/tools$ export
ADBHOST=10.118.198.117
ch...@marvin:~/android-sdk-linux_x86-1.5_r3/tools$ ./adb kill-server
ch...@marvin:~/android-sdk-linux_x86-1.5_r3/tools$ ./adb devices
* daemon not running. starting it now *
* daemon started successfully *
List of devices attached
emulator-5554   device

ch...@marvin:~/android-sdk-linux_x86-1.5_r3/tools$ ./adb shell
- exec '/system/bin/sh' failed: Bad address (14) -
ch...@marvin:~/android-sdk-linux_x86-1.5_r3/tools$ ./adb -s
emulator-5554 shell
- exec '/system/bin/sh' failed: Bad address (14) -


Am I doing something wrong?  Can anyone point me in the right
direction?  Thanks in advance.

--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---



Can't get adb shell to connect to real M912

by RaviY » Tue, 25 Aug 2009 01:04:34 GMT


 We are seeing a similar error every once in a while ...
- exec '/system/bin/sh' failed: Bad address (14) -

Any suggestions?

Thanks,
Ravi



--~--~---------~--~----~------------~-------~--~----~

-~----------~----~----~----~------~----~------~--~---


Sponsored Links


Other Threads

1. A simple question - I hope

Hi - I am simply looking for a way to get the total Ram available to
the device.  I have been able to get available Ram from a MemoryInfo
object with no problems, but what I really want to know is what
percentage is available - and so need the total.  The Runtime methods
give absurdly low values.  Is there a simple way to do this?  Do I
have to go into the ndk to get at /proc/meminfo?

Thank you,

Jonathan

-- 

2. Making HorizontalScrollView scroll programatically

Hi viktor,

I am not using the gallery view because I am using the horizontal
scroll view as a tab control in which every Bitmap I have added acts
like an individual tab?

SO in horizontal scroll view is it possible?






-- 

3. Reboot bug?

4. Sending email by Intent... not simply composing a message

5. Desire NexTSense Official Sense-FroYo 2.2

6. apps2sd widgets

7. How to use Toast.makeText in Service