Strange WebView "Web Page Not Available" behavior after application runs for a long time

by Kenn Min Chong » Tue, 05 Jan 2010 12:47:34 GMT


Sponsored Links
 Hey there!
   So, I have this simple app that contains a WebView object. My code
basically tells my WebView object to load some pages every minute or
so. The problem is, after the application runs for about 9-10 sites,
every time I ask the WebView object to load a new URL I get a "Web
page not available" error. Why is this happening?

--



Strange WebView "Web Page Not Available" behavior after application runs for a long time

by Kenn Min Chong » Sat, 09 Jan 2010 03:32:07 GMT


 Alright, I think I narrowed down the issue. Once my WebView gets stuck
in an "unresolveable" state, I tried to use the Browser app instead in
the emulator, and it no longer is able to resolve and URL I give.
HOWEVER, if I give it the IP address of the site instead, it works
just fine! So, I think there is something wrong with it when it tries
to resolve a name. Any ideas on how to resolve this?



> page not available" error. Why is this happening?


Sponsored Links


Other Threads

1. android 10

Rekan2 mau tanya ttg android syukur2 kalo ada 101 nya 
Krn pengetahuan saya ttg android cethek sekali 

Setahu saya ttg android hanya lah android itu os, dan perangkst yang 
mengaplikasi khan cuma htc 


TIA
Regard's


Ferry Kurniawan
Property Agent - Jual Beli Sewa Jogja & sekitar
Telp : 081. 82. FERRY ( 33779 )

-- 
"Indonesian Android Community [id-android]" 

2. mau tanya?

halo bro n sist........

btw ad gk yah pemakai android yg tinggal di jambi???/

jd kn bisa share mslh android scr langsung.....

-- 
"Indonesian Android Community [id-android]" 

3. report setelah upgrade cm beta4

4. How to keep WiFi from going to sleep?

5. rogue setting of device_provisioned, issue 4358

6. unicode chars not being dispatched from IM

7. Unable to parse hprof dump with MAT?