Error opening editor (layout)

by arnouf » Sun, 14 Sep 2008 18:12:19 GMT


Sponsored Links
 ello all,

I'm trying to port my Ashopper project on 0.9...
I've a problem to use Android Layout editor. Apparently some of my
layout files are bad and when I try to launch the new tool Android
Layout editor, this is crashed. I get the following error:
"Error opening the editor". When i click on the "details" button I get
the following exception. FYI, I'm using eclipse 3.2. I can compile and
run my Android apps.
Thank you for your help.

java.lang.NullPointerException
at
org.eclipse.osgi.framework.internal.core.BundleLoader.getLoaderProxy(BundleLoader.java:
253)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.createExportPackageSource(BundleLoader.java:
225)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.getImportedSources(BundleLoader.java:
215)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findImportedSource(BundleLoader.java:
908)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:
393)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:
369)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:
357)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:
83)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:
161)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:
501)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:
471)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:
430)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:
413)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:
189)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:
340)
at
org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:
37)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:
405)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:
369)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:
357)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:
83)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
at java.lang.Class.getConstructor0(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrate



Error opening editor (layout)

by Xavier Ducrohet » Mon, 15 Sep 2008 00:37:23 GMT


 'm not 100% sure this is related, but the latest plugins require Eclipse 3.3

Xav

On Sun, Sep 14, 2008 at 3:12 AM, arnouf <[EMAIL PROTECTED]> wrote:

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Error opening editor (layout)

by arnouf » Mon, 15 Sep 2008 01:24:56 GMT


 ooo!! I upgraded my Eclipse installation from 3.3 to 3.2 because I
saw on installation guide that 3.2 was required...It should be 3.3???

Hummm...I'll try this later and I come back to give a summarize !

Regards

On 14 sep, 18:37, "Xavier Ducrohet" <[EMAIL PROTECTED]> wrote:
--~--~---------~--~----~------------~-------~--~----~



Error opening editor (layout)

by Xavier Ducrohet » Mon, 15 Sep 2008 05:13:39 GMT


 revious plugins required 3.2 minimum. The new plugins that go with
the 0.9 SDK require 3.3 minimum.

Xav

On Sun, Sep 14, 2008 at 10:24 AM, arnouf <[EMAIL PROTECTED]> wrote:

--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. Customized date and time picker

Hi,

I want to customized date and time picker like i want to change the
background color, I want that user can't select back date.

Please help me in doing this.

-- 

2. David Wahyu wants to share their location with you on Google Latitude

David Wahyu (david.wa...@gmail.com) wants to share their location with you  
on Google Latitude. You too can see where your friends are and share your  
location using Latitude from your phone, computer, or both.


Aww snap. You don't have a Google Account.

To use Google Latitude, you'll need to sign in with a Google Account. If  
you don't have one, use the following steps:



Create a new Gmail account at https://mail.google.com/mail/signup or create  
a Google Account for your existing email address at  
https://www.google.com/accounts/NewAccount
Start using Latitude! Go to https://www.google.com/latitude from your phone  
or computer.
Sign in with your Google Account and add David Wahyu  
(david.wa...@gmail.com) as a friend.


(c) 2010 Google Inc., 1600 Amphitheatre Parkway, Mountain View, CA 94043,  
USA. Terms of Service | Privacy Policy


--
===============

3. Netconf4Android - Configuration Protocol on Android

4. Uploading Document to Google Docs

5. D

6. Volume Control ANR

7. PV Opencore on Gingerbread