video recording in 1.5

by Jason Proctor » Wed, 29 Apr 2009 15:04:16 GMT


Sponsored Links
 is video recording supported in 1.5?

i got it mostly working with the Haykuro 1.5 ADP image - the video 
file was legally formatted but didn't play properly.

with yesterday's official 1.5 images, it doesn't work at all. 
setVideoEncoder() fails, with the wonderfully informative error 
message "setVideoEncoder failed".

thanks for a position on this,
-- 
jason.software.particle

--~--~---------~--~----~------------~-------~--~----~



video recording in 1.5

by Jason Proctor » Sat, 02 May 2009 06:21:53 GMT


 (resend from different address, see if it makes it this time.)

is video recording supported in 1.5?

i got it mostly working with the Haykuro 1.5 ADP image - the video 
file was legally formatted but didn't play properly.

with the official 1.5 images, it doesn't work at all. 
setVideoEncoder() fails, with the wonderfully informative error 
message "setVideoEncoder failed".

thanks for a position on this,
Jason


--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


video recording in 1.5

by Dave Sparks » Sat, 02 May 2009 06:35:55 GMT


 Did you include android.permission.CAMERA in your manifest?



--~--~---------~--~----~------------~-------~--~----~



video recording in 1.5

by Jason Proctor » Sat, 02 May 2009 06:59:45 GMT


 nope, never needed it. is the requirement new?

i'll give it a go, thanks.

(looks like my posts are going to the list then. does the list not 
echo them back to the poster, like it used to?)




--~--~---------~--~----~------------~-------~--~----~



video recording in 1.5

by Dave Sparks » Sat, 02 May 2009 09:28:17 GMT


 No, you have always needed a camera permission to access the camera.
It's new to the MediaRecorder API because we didn't add video support
until 1.5.




--~--~---------~--~----~------------~-------~--~----~



video recording in 1.5

by Jason Proctor » Sat, 02 May 2009 09:42:56 GMT


 not to labour the point, but i ask whether it was new because i 
didn't need it with 1.5pre and the Haykuro image.

i'll give it a try when my ADP comes back, thanks.




--~--~---------~--~----~------------~-------~--~----~



Other Threads

1. x86 Creating filesystem error

I am building android for x86,when creating system.img,appear the
follow error.
Can anybody know how to fix it.

make_ext4fs -l 128M -a system out/target/product/generic_x86/obj/
PACKAGING/systemimage_intermediates/system.img out/target/product/
generic_x86/system
Creating filesystem with parameters:
    Size: 134217728
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8192
    Inode size: 256
    Journal blocks: 1024
    Label:
    Blocks: 32768
    Block groups: 1
    Reserved block group size: 7
error: do_inode_allocate_extents: Failed to allocate 141 blocks

-- 

2. Android CTS

Hi,

As am new to cts I don't know what I am doing is correct or not.
I build android 2.2 for beagleboard and start the CTS for this board.
I have android-cts zip and android SDK 2.2.
At cts console I give following command :-
start --plan CTS -p android.graphics.cts.BitmapFactoryTest;

and test got fail and I receive following stuff, in testResult.xml:-
-- testDecodeByteArray1 fail    junit.framework.AssertionFailedError at
android.graphics.cts.BitmapFactoryTest.testDecodeByteArray1(BitmapFactoryTest.java:
116)
-- testDecodeByteArray2 fail    junit.framework.AssertionFailedError at
android.graphics.cts.BitmapFactoryTest.testDecodeByteArray2(BitmapFactoryTest.java:
132)

Can any one guilde me.

-Yogesh

--

3. issues in building GingerBread

4. how to track market search terms

5. how to check phone support torch mode..problem pls solve

6. OpenGL Problem with Sphere Texture Mapping

7. WTPaging : Renner Chen