Can not install the Developer Tools

by Mahou » Tue, 21 Apr 2009 01:35:45 GMT


Sponsored Links
 I have tried to install the android Developer Tools for a good 1 hour
now, I have deleted and reinstalled eclipse 3 times. Same goes with
the JRE/JDK.

And nothing works, here the error I am getting. I have no clue what
the problem is. Can anyone help me out here?

An error occurred during provisioning.
  Failed to prepare partial IU: [R]com.android.ide.eclipse.ddms
0.8.0.v200809220836-110569.


^ I get that error when I do the Help > Software Updates, Available
Updates...

--~--~---------~--~----~------------~-------~--~----~



Can not install the Developer Tools

by Mahou » Tue, 21 Apr 2009 01:37:30 GMT


 I get this error when I try to install the Developers Tools.

An error occurred during provisioning.
  Failed to prepare partial IU: [R]com.android.ide.eclipse.ddms
0.8.0.v200809220836-110569.


I have already download and reinstalled the JDK/JRE and eclipse three
times.

I made sure the Path for the android SDK woks properly as well.

--~--~---------~--~----~------------~-------~--~----~


Sponsored Links


Other Threads

1. App opens previous activity - but only intermittently

Hi all,

This is an intermittent bug in one of my apps. I don't expect anyone
to solve it immediately, but I'd appreciate any thoughts on how to
start debugging!

So, my app lets users edit an item (in the EditPage activity). When
they press the Back key, the desired behaviour is that it saves their
edits and returns them to the home page (the HomeList activity). The
code for this is below. It works fine. Except...

The bug is this. Some users report that sometimes when they reopen the
application after a pause, they are seeing *not* the home page, where
they left the application - but the previous edit activity. Crucially,
they are also seeing the edit activity without their saved edits -
effectively losing their most recent edits :(

I've been able to reproduce this myself. It only happens after the
application hasn't been opened for a while. If I save something,
minimize the application and reopen it straight away, it shows the
HomeList activity just fine, and the edits have all been saved. But if
I save something, leave it for a couple of hours and then reopen it,
it shows the previous EditPage activity, without the saved edits (i.e.
in the state that the EditPage activity was previously launched).

Any ideas, anyone? I had wondered whether it was due to the Back
button being used to return the user to the HomeList activity - maybe
Android thinks that the Back button means that the HomeList is not the
most "recent" activity, instead the EditPage is. I'd like to carry on
using the Back button if possible, though. And in particular, I'm
puzzled why it only happens after the app has been idle for an hour or
so, and not immediately? Is it something to do with Android's memory
management?

As I say, would appreciate any tips on how to debug - quite baffled at
the moment!

Thanks very much,

Anna

----------

Code used in the EditPage activity to save edits when the Back key
gets pressed. Works fine, apart from bug described above.

        // Save everything when the Back key gets pressed
        public boolean onKeyDown(int keyCode, KeyEvent event) {
                if (keyCode == KeyEvent.KEYCODE_BACK) {
                        if (saveEdits()) {
                                Context context = getApplicationContext();
                                CharSequence text = "'" + title + "' has been 
saved";
                                int duration = Toast.LENGTH_SHORT;
                                Toast toast = Toast.makeText(context, text, 
duration);
                                toast.show();
                                Intent i = new Intent(EditPage.this, 
HomeList.class);
                                startActivity(i);
                        } else {
                                // failed to save!
                                showDialog(SAVE_WARNING);
                        }
                }
                return false;
        }
--~--~---------~--~----~------------~-------~--~----~

2. emulator doesn't shows up

Hi,


I'm a beginner for android apps development.I use netbeans to develop
java apps so decided to integrat android with it.
  I downloaded the nbdroid plugin and apache ant .I installed apache
ant successfully, installed the plugin, gave the path of the SDK to
netbeans.But after creating hello world application the emulator
doesn't shows up and the following message shows up
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
init:
deps-jar:
Compiling 1 source file to C:\Documents and Settings\Deepak Kumar
Shukla\My Documents\NetBeansProjects\AndroidApplication4\build\classes
compile:
Updating zip: C:\Documents and Settings\Deepak Kumar Shukla\My
Documents\NetBeansProjects\AndroidApplication4\dist
\AndroidApplication4.apk_
Using keystore: C:\Documents and Settings\Deepak Kumar Shukla\.android
\debug.keystore
Deleting: C:\Documents and Settings\Deepak Kumar Shukla\My Documents
\NetBeansProjects\AndroidApplication4\dist\AndroidApplication4.apk_
jar:
Result: -1
C:\Documents and Settings\Deepak Kumar Shukla\My Documents
\NetBeansProjects\AndroidApplication4\nbproject\build-impl.xml:544:
Device's package manager not ready to install new packages
BUILD FAILED (total time: 50 seconds)
--------------------------------------------------------------------------------------------------------------------------------------------------------------------

Be ensured about the installation of apache ant as I am able to run
commands like "ant -h" from the command prompt.
Also, I am able to create new avds for any platform (android 1.1 ,
1.5;Google APIs).

Message displayed on building the solution for the application is as
follows:
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
init:
deps-clean:
Deleting directory C:\Documents and Settings\Deepak Kumar Shukla\My
Documents\NetBeansProjects\AndroidApplication4\build
Deleting directory C:\Documents and Settings\Deepak Kumar Shukla\My
Documents\NetBeansProjects\AndroidApplication4\dist
clean:
init:
deps-jar:
Created dir: C:\Documents and Settings\Deepak Kumar Shukla\My Documents
\NetBeansProjects\AndroidApplication4\build\classes
Compiling 2 source files to C:\Documents and Settings\Deepak Kumar
Shukla\My Documents\NetBeansProjects\AndroidApplication4\build\classes
compile:
Created dir: C:\Documents and Settings\Deepak Kumar Shukla\My Documents
\NetBeansProjects\AndroidApplication4\dist
Updating zip: C:\Documents and Settings\Deepak Kumar Shukla\My
Documents\NetBeansProjects\AndroidApplication4\dist
\AndroidApplication4.apk_
Using keystore: C:\Documents and Settings\Deepak Kumar Shukla\.android
\debug.keystore
Deleting: C:\Documents and Settings\Deepak Kumar Shukla\My Documents
\NetBeansProjects\AndroidApplication4\dist\AndroidApplication4.apk_
jar:
BUILD SUCCESSFUL (total time: 0 seconds)

--------------------------------------------------------------------------------------------------------------------------------------------------------------------

I'm not able to make out how to solve this problem.
Please help me out.

Thanks.

--~--~---------~--~----~------------~-------~--~----~

3. Problem of vertical alignment in a RelativeLayout

4. How to listen for touch events from *Lock Screen* and *Home Screen*

5. Android GUI PSD

6. Is the Android team ever going to take responsibility for the terrible Android Market?

7. Hello MapView tutorial